[CentOS] CentOS7 - Serial Console and Flow Control

Fri Oct 16 14:12:55 UTC 2015
Mike - st257 <silvertip257 at gmail.com>

I started to compose this message, then got busy with other work...
Hopefully I'll have better details by the end of today.

Thanks Lamar!

On Thu, Oct 15, 2015 at 3:54 PM, Lamar Owen <lowen at pari.edu> wrote:

> On 10/15/2015 03:05 PM, Mike - st257 wrote:
>> Would anyone be so kind as to share their experience?
>> What has worked for your BMC/SoL configurations?
> I have a C7 server with a physical RS-232 console, but the config should
> be similar.  I did not have to generate a systemd service for this; systemd
> saw the console line and automatically started the getty without me having
> to generate a .service file (as far as I recall all I had to do was
> generate the proper /etc/default/grub, and then run 'grub2-mkconfig -o
> /boot/grub2/grub.cfg' and it Just Worked).
> Now, I have the system set for console on both the VGA and on ttyS0, and I
> am not using flow-control.  Here's what I have that works (again with a
> physical ttyS0):
> [root at backup670 ~]# cat /etc/default/grub
> GRUB_SERIAL_COMMAND="serial --unit=0 --speed=9600 --word=8 --parity=no
> --stop=1"
> GRUB_TERMINAL_OUTPUT="console serial"

I didn't have Term Output specified as you do. Probably the biggest problem
right there, g'ah!
( will know when I have a moment to test )

> GRUB_CMDLINE_LINUX="rd.md.uuid=long-uuid-string crashkernel=auto rd.lvm.lv=vg/swap
> rd.lvm.lv=vg/root rd.md.uuid=another-long-uuid console=tty0
> console=ttyS0,9600 rd_NO_PLYMOUTH"

I didn't have the option to disable Plymouth.

I see you don't have flow control enabled, otherwise you'd have 9600n8r
I'll try it without n8r.

> Also see: http://0pointer.de/blog/projects/serial-console.html
> There should be no need to modify any .service files; simply editing
> /etc/default/grub and regenerating grub2's

The baud rate I used is not specified in any of the service files systemd
But as you've said I should _not need_ a service file (which is much like
CentOS6 behaved with serial kernel params).

> config should be enough; it was in my case (I verified by looking through
> root's .bash_history and finding the lines around editing /etc/default/grub
> and not finding any edits of any .service files....)
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

//  SilverTip257  //