[CentOS] problem on exceptional quit

Thu Oct 8 02:33:55 UTC 2015
Hua Wang <ehwang at 163.com>

Dear Centos Users:

I installed Centos 7 on my server a few months ago. While using ssh, there is always a strange message "Write failed: Broken pipe”. It forces quit of SSH. It’s really annoying as it happens very often with irregular time interval - from a couple of minutes to a few hours. I have been working using Linux (Red Hat, Fedora and Centos) over 15 years. This didn’t happen for me even under centos 6.6. I have tried the following approaches, but none of them can help. I wonder if it can be solved by reinstall the system again. But it’s time consuming to reinstall a lot of softwares.

1. Login via Mac, Windows, Linux systems from different computers.
2. Modify sshd_config on the server as suggested by many posts:
TCPKeepAlive yes
ClientAliveInterval 60
3. Modify ~/.ssh/config file on my local computer:
Host *
ServerAliveInterval 60
4. Login ssh using -Y instead of -X.
5. add ‘unset autologout’ in my .cshrc.
6. I checked IP address with the internet administrator, and it works well.
7. add a file named autologout.csh with ‘set autologout=0’.

Do you know a good solution? Thanks!



Hua Wang, Ph.D. in Geodesy
Department of Surveying Engineering,
Guangdong University of Technology,
100 Waihuan Xi Rd., Panyu District,
Guangzhou, 510006, China.
Tel: +86-13570019257
Email: ehwang at 163.com
Homepage: http://homepages.see.leeds.ac.uk/~earhw