[CentOS] Centos 7, systemd, and nvidia drivers

Thu Sep 17 10:53:53 UTC 2015
mark <m.roth at 5-cent.us>

On 09/16/15 19:50, Jonathan Billings wrote:
> On Sep 16, 2015, at 5:21 PM, m.roth at 5-cent.us wrote:
>> I tried systemctl start multi-user.target. I tried systemctl stop
>> graphical.target. I finally had to set the multi-user.target as the
>> default, and reboot, to get rid of the nouveau drivers.
>> Note that I tried to modprobe -r, and rmmod with all the modules using
>> nouveau, and couldn't - I kept getting "in use" - it seemed like a
>> circular reference.
>> As I said, I rebooted. Then I ran the proprietary build, ran fine. I try
>> starting the graphical target, no joy. I changed the default target back
>> to graphical, and rebooted. Still no xorg. Googling (yahooing?), I added
>> rdblacklist=nouveau in grub.conf, *then* had to rebuild the grub2 (grub2
>> must *die*).
>> Still wouldn't see the nvidia drivers on reboot. Finally, I rebuild the
>> initramfs, which got the now-built and installed nvidia drivers (and I'd
>> yum uninstalled nouveau), and finally, it came up.
>> Oh, and for some reason, without the reboot, the Xorg.0.log wasn't
>> renewed, as though it hadn't actually restarted X. Plus, it appears that
>> <ctrl-alt-bkspc> is disabled....
> Of course, none of this had anything to do with systemd, other than the
> commands you had to change runlevels.  It’d be the same problem with
> Upstart in CentOS6, just different commands.  The kernel modesetting stuff
> is at fault here.  But who needs facts to get in the way of a good rant?

Really? In Centos 6, if I do an init 3, it shuts down X; none of the above did 
> I suggest looking at http://elrepo.org/tiki/kmod-nvidia

I'm familiar with elrepo.