[CentOS] Centos 7, systemd, and nvidia drivers

Wed Sep 16 21:21:10 UTC 2015
m.roth at 5-cent.us <m.roth at 5-cent.us>

Or, another rant against systemd. Moderators, put up with it - this is an

I tried systemctl start multi-user.target. I tried systemctl stop
graphical.target. I finally had to set the multi-user.target as the
default, and reboot, to get rid of the nouveau drivers.

Note that I tried to modprobe -r, and rmmod with all the modules using
nouveau, and couldn't - I kept getting "in use" - it seemed like a
circular reference.

As I said, I rebooted. Then I ran the proprietary build, ran fine. I try
starting the graphical target, no joy. I changed the default target back
to graphical, and rebooted. Still no xorg. Googling (yahooing?), I added
rdblacklist=nouveau in grub.conf, *then* had to rebuild the grub2 (grub2
must *die*).

Still wouldn't see the nvidia drivers on reboot. Finally, I rebuild the
initramfs, which got the now-built and installed nvidia drivers (and I'd
yum uninstalled nouveau), and finally, it came up.

Oh, and for some reason, without the reboot, the Xorg.0.log wasn't
renewed, as though it hadn't actually restarted X. Plus, it appears that
<ctrl-alt-bkspc> is disabled....

Then all I had to do was fight and hand-edit the xorg.conf, which *MUST*
be in /etc/X11/sorg.conf.d to be even seen.... But what I had to do is
beyond this - my user's got three monitors, on two cards, and two are for
3D, and so nothing to do with my issues with trying to get systemd to load
and xorg to use the nvidia drivers.

            mark, incredibly frustrated