[CentOS] Problem updating ddclient

Thu Apr 21 11:26:42 UTC 2016
Timothy Murphy <gayleard at eircom.net>

when I ran "sudo yum update" on my CentOS-7.2.1511 today,
ddclient was updated to ddclient-3.8.3-1.el7.noarch (from 3.7.3),
and ddclient.conf was moved to ddclient.conf.rpmsave .

When I move it back, "sudo systemctl restart ddclient"
fails with the error (in "sudo journalctl -xe | grep ddclient")
  Apr 21 13:05:39 alfred.gayleard.eu.localdomain touch[8590]: /bin/touch: 
  cannot touch ‘/var/cache/ddclient/ddclient.cache’: Permission denied

I see that when updating ddclient a new group ddclient was created.
I've tried various methods, eg deleting ddclient.cache,
re-installing ddclient,
creating a new ddclient.cache owned by root.ddclient, etc,
but without success.
Running "sudo systemctl restart ddclient" either fails, or hangs.

Any advice gratefully received.

Is there a way to go back to the previous version of ddclient?
when I try "sudo yum downgrade ddclient-3.7.3" 
I'm told "No package ddclient-3.7.3 available"

Timothy Murphy  
gayleard /at/ eircom.net
School of Mathematics, Trinity College, Dublin