[CentOS] Badlock bad luck

Sat Apr 16 15:54:11 UTC 2016
Bob Smith <bobsmith at dbata.com>

>* Am 13.04.2016 um 07:51 schrieb Mogens Kjaer <mk at lemo.dk <https://lists.centos.org/mailman/listinfo/centos>>:
*> >* Hello,
*> >* I run a CentOS 6 machine with samba, serving approx. 150 Windows
users with samba running as an NT-like PDC.
*> >* After today's samba update (samba-3.6.23-30.el6_7.x86_64 etc.),
nobody can log in.
*> >* They all get the "Trust relationship failed" error message.
*> >* If I downgrade:
*> >* yum downgrade samba-common samba-winbind samba-winbind-clients
samba-client samba samba-doc samba-domainjoin-gui libsmbclient
*> >* - the problem goes away.
*> >* What am I missing?
*> >* Mogens
*> >* --
*>* Mogens Kjaer, mk at lemo.dk
*>* http://www.lemo.dk <http://www.lemo.dk/>
*>* _______________________________________________
*>* CentOS mailing list
*>* CentOS at centos.org <https://lists.centos.org/mailman/listinfo/centos>
*>* https://lists.centos.org/mailman/listinfo/centos

Adding the following to the global section of smb.conf worked for me:

client signing = required
server signing = auto


The Community forum at ClearOS has a sticky thread on this topic.

The thread link is at


Thread info:

- Bug

- Badlock information hub

- This thread is to track and register information in regards to the
Badlock bug which is scheduled to release on April 12th 2016 at around
1700 UTC. As soon as we have a fix will will need extensive and
concentrated testing. More details will follow.