[CentOS] Semi-OT: very weird vi behaviour

Wed Apr 27 14:05:19 UTC 2016
m.roth at 5-cent.us <m.roth at 5-cent.us>

Richard wrote:
>> Date: Wednesday, April 27, 2016 13:43:00 +0000
>> From: "Vanhorn, Mike" <michael.vanhorn at wright.edu>
>> On 4/27/16, 9:39 AM, "centos-bounces at centos.org on behalf of
>> m.roth at 5-cent.us" <centos-bounces at centos.org on behalf of
>> m.roth at 5-cent.us> wrote:
>>> And now, I just
>>> ssh'd in from another windows, same way... and the weirdness isn't
>>> there.
>>> Anyone have any clues as to what's going on with that one session?
>> It sounds as if, for some reason, in that one session, vi doesn’t
>> know what your terminal settings are, so it’s in line editing
>> mode (like ed or ex). I don’t have an explanation as to why it
>> would only happen with that one session, though.
> Or your "colors" could be set oddly in that terminal window/vi
> session.
> Unfortunately you are giving almost no details - OSs (original and
> target machine), shells, terminal settings, etc., so it's hard to do
> more than jump to potentially rash conclusions.

Sorry, original machine that I sudo'd to root is CentOS 6; the machine
where it was acting weird was CentOS7. Terminal is rxvt, and my colors are
set everywhere to be the color Ghod (and IBM) meant them to be, green on
black. <g>

I'd been googling, and tried reset, and tried <ctrl-L>, and none of it
helped. I renamed /root/.viminfo, and tried vi -V, which showed it only
going after /etc/virc and /etc/vimrc, and neither modified. I also tried
vi --noplugin.