[CentOS] Custom desktop menu entries: weird behavior with menu categories

Sun Aug 14 09:33:56 UTC 2016
Nicolas Kovacs <info at microlinux.fr>


For my client's desktops, I'm usually customizing the various Linux
desktops I'm installing. I'm using custom icon themes (Elementary),
custom system fonts (Droid Sans), and one of the things I also customize
are desktop menu entries.

Here's an example of what I do on a Slackware+Xfce-based desktop, so you
get the idea. Once all applications are installed, I run the
cleanmenu.sh script:


As you can see, this script replaces the various *.desktop files in
/usr/share/applications and similar places with my own custom *.desktop


This solution has worked very well over the years. There are a few
reasons I'm doing this. Most of my users come from a Windows-centric
world, so it's better for them if the menu sports something like
"Office>Presentation Software" instead of "LibreOffice Impress". Another
reason is visual consistency. BTW, the "Elementary Xfce" icon theme is
great not only for Xfce, but also for other desktops, and it fits great
in corporate environments needing something sober and not too
distracting. Last but not least, some menu entries are better organized
in different categories. IMHO, the screenshot utility should default to
"Graphics" and not to "Utility", and Brasero should be in "Utilities"
and not in "Multimedia".

Curiously enough, some menu entries stubbornly refuse to have their
category redefined.

1. When I edit gnome-terminal.desktop and define "Categories=System;",
it won't appear in "Outils systèmes" as expected but remains in

2. I have a category "Divers" (something like "Misc") with a single
desktop entry for Printer Configuration. Now when I edit
system-config-printer.desktop and define something like
"Categories=System;", the "Divers" category remains there and the menu
entry won't budge.

Most of the menu entries can be redefined OK, and they appear in the new
category. Why a handful of desktop entries would not work remains a
mystery. This looks damn well like a bug, although I wouldn't even know
how to call it.

Any ideas?

Cheers from the sunny South of France,

Microlinux - Solutions informatiques durables
7, place de l'église - 30730 Montpezat
Web  : http://www.microlinux.fr
Mail : info at microlinux.fr
Tél. : 04 66 63 10 32