[CentOS] Kickstart issue with UEFi

Tue Aug 23 06:31:34 UTC 2016
Phil Manuel <phil at zomojo.com>

On Tue, 23 Aug 2016 at 02:18 Gordon Messmer <gordon.messmer at gmail.com>

> On 08/21/2016 11:56 PM, Phil Manuel wrote:
> > part /boot/efi --fstype="efi" --size=200 --ondisk=sda
> > And I have tried the latter with location as mbr still fails
> > What am I missing ?
> I very vaguely remember struggling with this as well, but I can't find
> my notes from that work at the moment.
> My kickstart files for non-RAID UEFI boots use something like this:
>     bootloader --location=mbr --append="net.ifnames=0 biosdevname=0"
>     part /boot/efi --ondrive=sda --fstype=efi --label EFI
>     part /boot --fstype=ext4 --ondrive=sda
>     ...
> My memory is really fuzzy, but if I remember right, this didn't work
> when I didn't specify "--label EFI" or some other really silly thing.  I
> think I resolved the problem by doing a manual install and then working
> with the anaconda.ks file until I was satisfied.
OK So I tried your suggestion no joy.  Installed i manually.  Took the
kickstart file from this install, and tried to use this as the install
kickstart.  It failed.  I deleted all the partitions and tried again no
joy, the default ks is  as follows:-

# Use network installation
url --url=""
# Use text mode install
ignoredisk --only-use=sda,sdb
# Keyboard layouts
keyboard --vckeymap=us --xlayouts='us'
# System language
lang en_US.UTF-8

# Network information
network  --bootproto=dhcp --device=enp0s31f6 --ipv6=auto --activate
network  --hostname=localhost.localdomain

# Root password
rootpw --iscrypted
# Do not configure the X Window System
# System timezone
timezone Australia/Sydney
# System bootloader configuration
bootloader --append=" crashkernel=auto" --location=mbr --boot-drive=sda
autopart --type=lvm
# Partition clearing information
clearpart --all --initlabel --drives=sda,sdb



%addon com_redhat_kdump --enable --reserve-mb='auto'


Should I need to change anything to this ?