[CentOS] Problem with yum on CentOS Linux release 7.2.1511 (Core) with 3.10.0-327.36.3.el7.x86_64 kernel

Wed Dec 14 13:44:54 UTC 2016
Gregory P. Ennis <PoMec at PoMec.Net>


I am at a loss on this problem would appreciate some guidance as to
where to start to fix it.

I noticed that my home gateway server was not being updated with the
new kernel and other software, and when I ran yum it aborted with the
following notices.  I tried a yum clean all, but this did not fix the
problem.  I thought the problem may be related to one of the repos, but
I have other machines in the same network that update properly.  I
disabled all repos except the BASE to try to simply the problem and
still the same problem.

Any help would be appreciated.


Greg Ennis

Loaded plugins: aliases, changelog, fastestmirror, langpacks, product-
id, search-
              : disabled-repos, subscription-manager, tmprepo, verify,
This system is not registered with Subscription Management. You can use
subscription-manager to register.
base                                                          | 3.6
kB  00:00:00     
(1/2): base/7/x86_64/group_gz                                 | 155
kB  00:00:00     
(2/2): base/7/x86_64/primary_db                               | 5.6
MB  00:00:01     
Determining fastest mirrors
 * base: centos.mirror.lstn.net
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 365, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 174, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 573, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self,
self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 500, in doCommand
    ret = base.updatePkgs(extcmds, update_to=(basecmd == 'update-to'))
  File "/usr/share/yum-cli/cli.py", line 1015, in updatePkgs
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5114,
in update
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5328,
in update
    available_pkg, updated_pkg)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 5033,
in _add_up_txmbr
    txmbr = self.tsInfo.addUpdate(upkg, ipkg)
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line
518, in addUpdate
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line
289, in add
    self.addUpdated(oldpo, txmember.po)
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line
547, in addUpdated
    txmbr = TransactionMember(po)
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line
830, in __init__
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1946, in
    res = self._read(attr)
  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1861, in
    info = misc.stat_f(fn, ignore_EACCES=True)
  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 962, in
    return os.stat(filename)
OSError: [Errno 5] Input/output error: