[CentOS] CentOS 6, firefox, PIV cards

Thu Dec 1 19:50:30 UTC 2016
m.roth at 5-cent.us <m.roth at 5-cent.us>

m.roth at 5-cent.us wrote:
> Hi, folks,
>    Up until a few weeks ago, it worked as it has been for years: firefox,
> security device is libcoolkey, and pcscd.
>    Today, I go to use it (I have done updates sine I last used it), and
> try preferences->advanced->certificates, and it hangs. My most recent
> try was for over 20 min. If you move something over the window, then
> move it away, it's a blank window. Pull out the card, and *some* of the
> time, it pops up the window showing no certs, having never asked for a
> PIN. The rest of the time, firefox crashes, hard.
>    I know the pcscd part works - I used it via a script this morning from
> the command line, as does pkcs15-tool from the command line.
>    Anyone got any clues? Maybe I should downgrade (if I can) firefox?
Additional info: I tried bringing up firefox with two other profiles. One
didn't have coolkey as a security device, but when I tried to add it, it
responded with "cannot add module".

Yet a third profile, that had both libcoolky and the older onepin, and
that popped up a window saying I needed to authenticate, sat there with no
way to put a pin in, then, when I pulled the card, it flashed the popup
window with my certs.

Yes, at this time, I'm looking at issues with firefox.

So - has anyone else had this problem?