[CentOS] CentOS 7 regression, can not take a KVM qcow2, convert it and boot it on ESXi...

Thu Feb 4 08:58:21 UTC 2016
John Hodrien <J.H.Hodrien at leeds.ac.uk>

On Thu, 4 Feb 2016, Martinx - ジェームズ wrote:

> My last try was, during Packer build, to append "add_drivers+="
> sd_mod" to /etc/dracut.conf and re-building initramdisk by running
> "dracut -f". However, it does not boot either (on ESXi)!
> I can still boot using Rescue mode on VMWare, then, I can see that
> sd_mod is inside of initramfs as expected (lsinitrd FTW) but, dracut
> does not load it! I tried "force_drivers+=" sd_mod", doesn't work
> too...
> Weird is that, while during Rescue, if I run "dracut -f" again, then,
> it works! Normal boot proceeds... But this is unacceptable, because I
> can not ship a half-broken VMDK and tell customers to first boot on
> Rescue, run "dracut -f" and then, use the system.
> So, why the heck the "dracut -f" executed when as a KVM guest have no
> effect for later ESXi usage?
> What am I missing?
> I really appreciate any help!

Is this possible the hostonly option in dracut causing fun?

"On RHEL-7 the hostonly mode is the default mode. Generic "non-hostonly"
  images are created, if the dracut-config-generic rpm is installed.  The
  rescue kernel entry in the bootloader menu is also a generic image."