[CentOS] C7 AD server

Sun Feb 7 09:38:35 UTC 2016
Alessandro Baggi <alessandro.baggi at gmail.com>

Il 07/02/2016 01:11, Miguel Medalha ha scritto:
>>> Try this. I have been thinking of trying it on C7.
>>> http://www.linuxhelp.net/forums/index.php?showtopic=10868
> I wouldn't follow the instructions on that link.
> Disable iptables? Nah!
> The author lumps SELinux and the firewall together.
> What is said about DNS is also misleading. DNS is crucial for AD.
> Please look at the Samba Wiki instead.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

Hi Miguel,
last link was outdated and I'm using samba4. Over this, I've used sernet 
samba version to accomplish this work.
First, the configuration with samba-tool is simpler. The new approach is 
a AIO solution.

Then, I've provisioned the domain without any problems and joined from 
win7 host. All works fine.

The next step that I tried to accomplish is create a share on this host 
and I've encountered problem with permission on shared dir.
If I try to access/write/read this share I get permission denied. 
Setting permission on 777 all works but this is not what I want. I've 
tried to verify the existence of create users and groups but on system 
(using getent) users are not seen on system and the same for groups.
On DC side, I can see user and group with wbinfo command.

Share file system is xfs.
At the moment Selinux and firewalld are disable for test purpose.
How I can assing permission on this share?