[CentOS] Issue with installation on wireless-only desktop workstation, CentOS 7(1511)

Thu Feb 4 15:17:28 UTC 2016
Lamar Owen <lowen at pari.edu>

I realize that many on this list have likely applauded the 
NetworkManager package split that removed wireless stuff into its own 
package, NetworkManager-wifi, because for wired workstations and servers 
it might be desirable to not have any wifi software installed.  And I 
believe it was a sound technical decision to do the split.

However, in doing a fresh installation of what most call CentOS 7.2, or 
7.2.1511, I ran into a real issue that required a bit of deep-diving to 
find, and a simple 'yum install NetworkManager-wifi' to fix.  (although 
my actual 'yum install' command included the full path to the actual RPM 
on the install media.......)

I have a personal workstation at home, a Dell Optiplex 745 with a 
Core2Quad Q6600, that is on the other end of the house from the router.  
While I could run cat5 to the location, it would involve quite a bit of 
labor, and I have a known-supported USB wifi nic based on the ralink 
rt3070 (cheap, but works well), so why should I run the cable when wifi 
should work well?  Especially given that the Dell is not going to be 
there for very long it wouldn't make sense to run cable.

Anyway, I configured the wifi network during installation (I actually am 
growing to like, even prefer, the hub-and-spoke anaconda), it associated 
with the WPA2-protected AP, grabbed an IP address, and all was good.  
Did the install; no errors.

I rebooted, and now there is no wireless.  At all.  Doing a bit of 
troubleshooting shows that the kernel sees the NIC, but NetworkManager 
shows it as 'unmanaged' ('nmcli d' is the command to use from a shell).  
So I warmed up my google-fu on my laptop and finally tracked it to a 
post that mentioned having to install NetworkManager-wifi.  Sure enough, 
on the workstation NetworkManager-wifi was not installed.  I mounted the 
USB install drive's ISO partition and manually installed it, restarted 
NetworkManager, and it now works just fine.

But why did anaconda not select the NetworkManager-wifi package to be 
installed if a wireless network connection was configured in the 
installer?  Anaconda should have some way of forcing the install of the 
appropriate NetworkManager modules if those are needed (but only if they 
are actually needed) for a configured connection during install.

I can file a bugzilla, but I thought I'd post about it here first to get 
an idea of which package in which to file the report, since it's not a 
bug in NetworkManager-wifi.  Anaconda? (that is my first impression of 
the proper place).

So if you have this situation arise where wifi doesn't work after 
install of current CentOS 7(1511) but does during install, manually 
install NetworkManager-wifi from the install media and that should clear 
it up.