[CentOS] CentOS7 changes strike again.

Sat Jan 30 17:15:44 UTC 2016
Rob Kampen <rkampen at kampensonline.com>

Still in the process of migrating from an old CentOS5 server to a brand 
new CentOS7.

After finally getting Virtualbox-5.0 installed and a new Wondoze10 Pro 
installed it became time to shift the data from the old server to the new.

The old server is headless and I installed the old WindozeXP into the 
Virtualbox4.x via the command line.
To do some of the admin I needed to attach to the windoze via a gui and 
used rdesktop via an ssh tunnel of port 3389. This "just worked" with my 
old CentOS6 laptop and workstations.

So now I try to connect to the old server via my laptop also running a 
recent CentOS7 install using rdesktop - no joy.
the ssh command is
 >ssh servername -L 3389:
and then also from my laptop
rdesktop -a 16 -N -u rkampen -p-

only to get
ERROR: Failed to open display:

various google searches offer suggestions
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

ERROR: Failed to open display: :0.0

tried setting selinux to permissive mode - still no joy.

All this just worked with my old CentOS6 laptop and work station, 
however I no longer have access to that.
I guess there have been some "improvements" with the advent of gnome3 
that now prevent this from working, however my knowledge of how this 
rdesktop interacts with the local display manager are sketchy at best.

Any suggestions from those of you that understand this stuff way better 
than I do?