[CentOS] realm discover

Thu Jan 21 01:13:08 UTC 2016
Henry McLaughlin <henry at incred.solutions>

On 21 January 2016 at 12:03, Warren Young <wyml at etr-usa.com> wrote:

> On Jan 20, 2016, at 5:52 PM, Henry McLaughlin <henry at incred.com.au> wrote:
> >
> > I am new to CentOS and trying to setup a Samba file server however when
> > discovering domains I receive an authorisation error:
> >
> > [root at sssd-testing ~]# id
> > uid=0(root) gid=0(root) groups=0(root)
> > [root at sssd-testing ~]# realm discover
> > realm: Couldn't discover realms: Not authorized to perform this action
> Double-posting, I see: http://unix.stackexchange.com/questions/256626/
> Have you tried giving the domain name?  DHCP might not be getting the
> correct one.
> (ObWarStory: We installed our system at a site a few months ago that used
> one domain name for their public web site and email, another for internal
> AD stuff, and gave us yet a third when we asked for AD login credentials.
> Needless to say, neither the first nor the third were the right values, and
> we had to go round and round with them until they admitted the existence of
> the second domain name.)
> Also, I’m pretty sure it’s not complaining about local permissions here.
> You should not have to be root to make this work.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

Hi Warren and thanks for the reply. I have tried both with and without the
domain name without success.