[CentOS] CentOS7 changes strike again.

Sat Jan 30 20:08:36 UTC 2016
Ken Smith <kens at kensnet.org>

Rob Kampen wrote:
> Still in the process of migrating from an old CentOS5 server to a 
> brand new CentOS7.
> After finally getting Virtualbox-5.0 installed and a new Wondoze10 Pro 
> installed it became time to shift the data from the old server to the 
> new.
> The old server is headless and I installed the old WindozeXP into the 
> Virtualbox4.x via the command line.
> To do some of the admin I needed to attach to the windoze via a gui 
> and used rdesktop via an ssh tunnel of port 3389. This "just worked" 
> with my old CentOS6 laptop and workstations.
> So now I try to connect to the old server via my laptop also running a 
> recent CentOS7 install using rdesktop - no joy.
> the ssh command is
> >ssh servername -L 3389:
> and then also from my laptop
> rdesktop -a 16 -N -u rkampen -p-
> only to get
> ERROR: Failed to open display:
> various google searches offer suggestions
> prepending
> DISPLAY=:0.0
> gives
> Xlib: connection to ":0.0" refused by server
> Xlib: No protocol specified
> ERROR: Failed to open display: :0.0
> tried setting selinux to permissive mode - still no joy.
> All this just worked with my old CentOS6 laptop and work station, 
> however I no longer have access to that.
> I guess there have been some "improvements" with the advent of gnome3 
> that now prevent this from working, however my knowledge of how this 
> rdesktop interacts with the local display manager are sketchy at best.
> Any suggestions from those of you that understand this stuff way 
> better than I do?
> Rob

When I do this with KVM I need to use the IP that the VM is using on the 
virtual bit of LAN that KVM emulates so my commands would be something like

ssh servername -L 3389:


rdesktop -a 16 -N -u rkampen -p-

Where is the IP of the VM

What happens is that the SSH command produces a tunnel that links port 
3389 on the source machine to port 3389 at IP on the 
destination machine.

Then the rdesktop command connects to the tunnel on your source machine 
on port 3389 which is then tunnelled to the destination at IP port 3389, via what the SSH command did.

In the shell you get to on 'servername', as a result of the SSH command, 
can you telnet 3389 and get a connection? Obviously 
substitute the real IP of the VM. If you can, then the VM is listening 
and accessible on port 3389. Is the firewall on the virtual host 
allowing the incoming traffic on 3389 to reach the VM?

Hope that helps a little


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.