[CentOS] SAS drive not showing [SOLVED]

Thu Jul 28 19:55:51 UTC 2016
m.roth at 5-cent.us <m.roth at 5-cent.us>

*Finally* found the answer. The case was, if you'll recall, that I had
replaced a pair of older, smaller drives with a couple of 8TB SATA drives,
and made it RAID1 using the PERC firmware. I was then going to wipe the
drive. First, the old ones turned out to be SAS, no SATA. I had tried
shoving it into a similar Dell, which I regularly use for shoving SATA
drives in, and copying over the network, then putting them (larger drives)
in place of the ones they were replacing on other servers. This just
wouldn't show as /dev/sdx, the way the SATA did.

The solution: a script I found on the 'Net lsi.sh, which depends on you
having MegaRaid on the box, shows the four drives, but that one was listed
as "unconfigured good". What I needed to do was use MegaCLI64 to first
display foreign configurations... and regardless of the other three SATA
drives, did show only one, and that was from this SAS drive. I then did a
clear foreign configuration. After that, I could use PDMakeJBOD, and all
is wonderful.