[CentOS] how to update glib-2.28.8 to glib-2.40.0 or newer version

Fri Jul 1 16:57:59 UTC 2016
Jonathan Billings <billings at negate.org>

On Fri, Jul 01, 2016 at 01:54:53PM +0800, qw wrote:
> I'm trying to build gstreamer sdk on centos 6.7. When configure is
> run for 'gstreamer-1.8.2.tar.xz' on centos 6.7, error messages are
> reported as below: 
> checking for GLIB... no
> configure: Requested 'glib-2.0 >= 2.40.0' but version of GLib is 2.28.8
> configure: error: This package requires GLib >= 2.40.0 to compile.
> The command of 'yum install glib*' can only update glib to
> glib-2.28.8. How to update glib to the version of >=2.40.0 on centos
> 6.7? 

You're going to have to support your own version of glib (and not
replace the OS one) to get that working, most likely.  You might have
better luck getting the latest gstreamer to build on CentOS7, which
has glib2 2.42.2 packages.

CentOS (particularly, CentOS6 or CentOS5) isn't the best platform to
be building the latest versions of software like gstreamer, which is
already packaged and maintained at an enterprise level.

Jonathan Billings <billings at negate.org>