[CentOS] CentOS 6.7->6.8, ssh-add issue, followup, more info

Thu Jul 28 17:39:16 UTC 2016
m.roth at 5-cent.us <m.roth at 5-cent.us>

Denniston, Todd A CIV NAVSURFWARCENDIV Crane wrote:
> Tue Jul 26 21:17:40 UTC 2016,  m.roth at 5-cent.us wrote:
>> I could try the reinstall, but it's very odd - everything worked, and
>> now, after the upgrade, it doesn't. Oh, and here's another twist on this:
>> Under 6.7, if I'd logged into my webmail via firefox, and while that was
>> happening, I stuck my AA ("Logical token" card) into the keyboard slot,
>> and used it in logging onto one server (using sccr), it just chugged
>> along. Now, at 6.8, *everything* in firefox hangs - even a google
>> search, until I pull the card out of the keyboard. It's clearly trying to
>> authenticate the client, not just the server....
> I think your use of openssh -s libcoolkeypk11.so makes it look like:
> ssh
> coolkey
> pcscd
> ccid
Some minor corrections, and more data: as I was typing, before I pulled my
PIV card out of the slot, and a second or two later, firefox crashed, so I
have to retype this....

I was doing ssh -i libcoolkeypk11.so <host> for debugging purposes. What I
used to do was ssh-add -s libcoolkeypk11.so. It would then ask for a PIN,
and add it. Now, it still asks for the PIN, but then announces that it
failed to add it to the agent. From messages, I see
ssh-pkcs11-helper[14669]: error: no slots, which I suspect is suggesting
some weird misconfiguration, because my manager, who originally got the
configuration working, tells me it shouldn't be using that.

Also, for a reader, lsusb shows  Dell Computer Corp. SmartCard Reader
Keyboard. More: when I used to insert the card, it would blink a bit,
maybe half a dozen times or so, and then stop. Now, it blinks for longer
(10?15?), then stops... but once I've tried to add the card and it fails,
it starts blinking, and doesn't stop.