[CentOS] VNC server issue- Gnome - oh no! Something has gone wrong

Wed Jun 29 14:00:09 UTC 2016
Johnny Hughes <johnny at centos.org>

On 06/29/2016 07:51 AM, Hersh wrote:
> Hi All,
> The other thing we have noticed after booting is, screen is completely
> blank. GUI is not visible on attached monitor.
> We tried switching between different terminals using (Ctl+Alt+F1-12). F2-6
> are showing command line terminals but, others are returning blank screen
> only.
> It appears that, there is some problem with GUI/gnome. Is there any way to
> fix this? Please help.

I am not a genius (by any stretch of the imagination :D) .. but I would
likely run an fsck on all the filesystem mounts .. I would likely use a
LIVE ISO to do that and make sure the hard drive is unmounted.

I would then likely try a GNOME group reinstall like this (as root)

yum reinstall @GNOME gdm

If none of that worked, then I would try reinstalling all the xorg-x11
packages I have installed on the machine.

If that did not work, I would buy a new hard drive, do a new install and
then use something like an external case to connect the old drive and
copy off any important stuff.

OR .. if I had backup, I would just restore it :D


Note, I am sure there are also any number of other things to try.  Maybe
someone else will opine.

Johnny Hughes

> On 28 June 2016 at 15:43, Hersh <parikhh1 at gmail.com> wrote:
>> I forgot to mention, I have followed steps mentioned in this link
>> https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/ch-TigerVNC.html
>> for configuring vnc.
>> I have also tried upgrading VNCserver but that didn't help either.
>> Regards
>> Hersh
>> On 28 June 2016 at 15:39, Hersh <parikhh1 at gmail.com> wrote:
>>> Hi,
>>> I have been using VNC on CentOS 7 server from last couple of months and
>>> it was running all fine till last night. Unfortunately, there was an abrupt
>>> power failure and system got restarted.  Now, when I try to login with
>>> VNCviwer, it thrown an error message-  "*Gnome - oh no! Something has
>>> gone wrong "*  with a logout option. When I click on logout, I see
>>> black/dark gray screen with 3 check boxes.
>>> I googled to figure out a solution and tried several solutions but could
>>> not fix the problem. Any suggestion would be very helpful.
>>> Regards
>>> Hersh
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20160629/034b121b/attachment-0005.sig>