[CentOS] Installing 32-bit CentOS 6 on a new Lenovo System x3650 M5 server?

Alfred von Campe alfred at von-campe.com
Thu May 19 00:35:15 UTC 2016

> On May 13, 2016, at 16:27, I wrote:
> Is there any known incompatibility with the latest 32-bit (i386) CentOS 6 and the latest Lenovo x3650 M5 servers?  I’ve been running i386 CentOS 6.X on 3 year old x3650 M4 servers without any issues.  Our development environment has not been ported to 64-bit (x86_64) yet, so we are stuck using i386 for another few months.  When I try to boot from the netinstall ISO image I just get a “Boot Failed” message. Has anyone had similar issues, and more importantly, figured out a way to workaround it?

I’ll answer my own question now that I’ve figured it out in case anyone else is in the same boat.  After the i386 CentOS 6 net install ISO failed to boot, I tried the LiveCD and minimal ISOs which failed in the same way.  Then I tried various x86_64 ISO images to no avail.  The only ISO image that I was able to boot from was the latest Ubuntu 16.04 LTS release.  But I really need i386 CentOS.  I was able to install it by clicking on a Legacy checkbox in the BIOS, which brought up a different list of boot devices and I was finally successful in booting from the ISO image.  I then had to finagle the BIOS to always boot in legacy mode so that it would recognize the i386 CentOS boot partition on each powerup.


More information about the CentOS mailing list