[CentOS] Centos 7 and Kably lake: black screen

Sat Nov 12 20:15:22 UTC 2016
Louis Lagendijk <louis at fazant.net>

I got a new laptop as my old one died: an HP Probook 470 G4. 
I installed Centos 7 1511.
The laptop has a Kaby Lake i5 CPU and an 
01:00.0 3D controller: NVIDIA Corporation Device 134e (rev a2). 
Fedora recognizes it as a GM108M/930MX. This may give some hints, but
it is not that the standard kernel does not support it, this output
comes from the 4.8.7 mainline kernel which should support this
configuration? GM108 support was added in kernel 4.7, Kaby lake support
was added in 4.5...

When I boot nothing shows up after the UEFI Grub menu: the system runs
but nothing is shown on the display, except for a non-blinking cursor
in the upper left of the screen. I tried a number of things:
- Installed the latest ml-kernel from Elrepo (4.8.7-1)
- I also tried the following on the kernel commandline:
	nomodeset i915.nomodeset=0 nouveau.modeset=0
Nothing changes the fact that there is no display.

I had to install Centos 7 using vnc as even a text install did not work

Does anybody have some idea what the cause could be and what to try