[CentOS] Trouble setting up HP Officejet Pro 8600 printer on CentOS 7 + KDE

Fri Nov 11 13:04:18 UTC 2016
Nicolas Kovacs <info at microlinux.fr>

Le 11/11/2016 à 12:37, Nicolas Kovacs a écrit :
> 1. Generally, I have two options. Either go with the 3.13.x HPLIP
> packages provided by RHEL/CentOS, or download the more recent (currently
> 3.16) HPLIP package on the HP site. Which way do you choose to go?

Later, after some more testing.

The hplip-gui package provided by RHEL/CentOS doesn't work with this
printer, though it *should*. Theory and practice...

I removed all HPLIP-related stuff and downloaded and installed the
hplipfull package provided by HP on their website. 'yum localinstall'
informed me about a few conflicting residual packages like hplip-libs
and hplip-common on my system. I removed these, and everyting went well.

First thing, I downloaded the plugin:

  # hp-plugin

I got rid of the old (non functional) printer configuration and started

  # hp-setup

The printer was added OK, but curiously enough, the test page was
completely blank. I tried to print something else and decided to try the
Firefox home page with the CentOS text. This printed OK.

Curiously enough, KDE's Skanlite application is completely missing from
the repos, so I installed simple-scan. I tried to scan a page, and the
scanner also works perfectly.

So the only remaining problem seems to be: why does the test page button
not work and only print out a blank page?



Microlinux - Solutions informatiques durables
7, place de l'église - 30730 Montpezat
Web  : http://www.microlinux.fr
Mail : info at microlinux.fr
Tél. : 04 66 63 10 32