[CentOS] HP CP2025

Mon Sep 26 21:45:15 UTC 2016
Kay Schenk <kay.schenk at gmail.com>

On 09/25/2016 06:09 PM, Mark LaPierre wrote:
> [mlapier at peach ~]$ rpm -qa | grep hplip
> hplip-common-3.14.6-3.el6.x86_64
> hplip-libs-3.14.6-3.el6.x86_64
> [mlapier at peach ~]$ rpm -qa | grep cups
> cups-1.4.2-74.el6.x86_64
> cups-pk-helper-0.0.4-13.el6.x86_64
> gutenprint-cups-5.2.5-2.el6.x86_64
> cups-libs-1.4.2-74.el6.x86_64
> cups-libs-1.4.2-74.el6.i686
> [mlapier at peach ~]$
> CentOS release 6.8 (Final)
> I've been able to print to this printer with no issues, until this
> evening.  When I tried to send a print job the job just sat in the print
> queue.  I killed the job and deleted the printer, then re-installed the
> printer using the Printer configuration tool found under
> System/Administration/Printing.

"until this evening"...so that's interesting.

I'm also on CentOS 6.8 but 32-bit using the same hplip version. Normally 
I do printer setup with hp-setup, then use the web interface to cups to 
add it in to that environment.

Also, add hp-systray to your startup apps if you haven't already.

> I've tried all manner of settings, both on the Libre Office document and
> in the Printer configuration tool.  Now I can print to the printer but I
> cannot get the printer to print in Landscape orientation.  Only portrait
> orientation comes out no matter what settings I choose.

Does portrait work with ANY other type of document -- pdf, for example?

> I've done a bit of Google work but I find nothing that appears
> applicable to my specific issue of not getting landscape prints no
> matter what setting I choose.

> The HPLIP web site says the latest version of hplip for my machine, RHEL
> 6 because they apparently have not heard of CentOS, is
> hplip-3.16.9_rhel-6.0.x86_64.  CentOS does not have this version
> available in the repo.
> What's a guy to do?  Windows should be this hard to work with, but not
> Linux.


"God helps those who help themselves."
                    -- popular adage