[CentOS] always boot from Elrepo kernel

Tue Sep 27 15:14:23 UTC 2016
Nicolas Thierry-Mieg <Nicolas.Thierry-Mieg at imag.fr>

On 09/26/2016 03:14 PM, Johnny Hughes wrote:
> On 09/26/2016 04:29 AM, johan.vermeulen7 at telenet.be wrote:
>> ----- Oorspronkelijk bericht -----
>> Van: "Jim Perrin" <jperrin at centos.org>
>> Aan: centos at centos.org
>> Verzonden: Donderdag 22 september 2016 17:19:42
>> Onderwerp: Re: [CentOS] always boot from Elrepo kernel
>> On 09/22/2016 10:14 AM, johan.vermeulen7 at telenet.be wrote:
>>> Hello All,
>>> I purchased some Dell Latitude 3570 laptops. They came with Ubuntu preinstalled. ( Which I swapped for Centos7)
>>> I have to use Elrepo kernel on these machines to get some of the fn function keys to work.
>>> So I installed Elrepo's kernel-ml and selected this kernel with:
>>> # grub2-set-default 0
>>> ( after disabling secure boot)
>>> The problem I see is that after a next kernel update, the new Centos kernel will be nr 0 and the machine will
>>> boot from that kernel if I tested this correctly.
>>> Is there a way I can enable elrepo kernel update but not the regular Centos kernel?
>> I believe you need to update /etc/sysconfig/kernel to set the 'default'
>> kernel package to be the kernel-ml or whichever elrepo kernel you're using.
>> Hello Jim,
>> thanks for the reply.
>> For some reason that doesnt' work.
>> To test this I booted from an older kernel and removed the most recent Centos-kernel
>> After installing Elrepo's kernel-ml the system boots from kernel-ml, with or without changing /etc/sysconfig/kernel to
>> DEFAULTKERNEL=kernel-ml
>> But after running an update again, and reinstalling the latest Centos kernel, the system boots from that kernel again.
> There is no reason to keep the CentOS Kernel on your machines if the
> elrepo kernel is what you want to use.

Well you might want to use kernel-ml by default and still get the Centos 
kernels installed so you can test them when updates are released, and 
move back to them when they start supporting your hardware.
In any case it does seem that DEFAULTKERNEL in /etc/sysconfig/kernel is 
not working as expected in C7. I'm pretty sure it worked in Centos6.