[CentOS] OT: I fixed and it wasn't broken

Wed Sep 21 00:31:46 UTC 2016
TE Dukes <tdukes at palmettoshopper.com>


I fixed it real good.

I bought a Lenovo TS130 ThinkServer about 5 or 6 years ago. Folks told me,
RHEL/CentOS would not run on this server.

I bought it and installed it and it works fine.

So, a couple weeks ago, I decided to upgrade the memory. At the time, the
bios only supported 16GB but it would be upgradable to 32GB.

So, I started adding memory and figured I needed to upgrade the bios so I
could get to 32GB.

I got through 2 updates with rufus 2.11 and FreeDOS. Both installed with no

On the third upgrade, my USB flash drive is no longer recognized as a boot
device. The fourth bios upgrade is a shell script run from RHEL which the
support was also added later. I tried that first but it didn't work. Didn't
get any errors, it just didn't work.

Lenovo says use rufus 2.2 which supports MS-DOS. I can't get that version to
create a bootable USB drive. It fails.

I have tried .iso images and adding the bios files to it for a bootable
DVD/CD. It boots but can't find the bios files. A dir of the DVD shows the

I've tried plopt and a couple others.

I'm stuck!!

Any help would be greatly appreciated.