[CentOS] sound problems... alsa & systemd?

Sun Apr 2 22:05:58 UTC 2017
Kay Schenk <kay.schenk at gmail.com>

HI. OK. I had a bit more time to check things out. I have full pulseaudio
installed on my setup under CentOS 6.8, including the hooks from alsa to
pulseaudio and hooks to pulseaudio from X server. Additionally, I have
PulseAudio Sound System in my startup applications from Centos 6.8, Gnome
2. That is what I had to manually cobble up on openSuSE.

Best of luck.

On Sun, Apr 2, 2017 at 10:31 AM, Kay Schenk <kay.schenk at gmail.com> wrote:

> On 03/29/2017 06:43 AM, ken wrote:
>> On 03/28/2017 08:53 PM, ken wrote:
>>> The www has failed me with this, so I'm trying you guys.  Sound worked
>>> great out of the box when I installed 7.2... Yay!  I could watch all
>>> kinds of videos, like on facebook and youtube.  And I could listen to
>>> most podcasts too.  But then something happened. It was either a
>>> kernel upgrade or that I installed vlc (for watching videos on DVD)
>>> and the whole stack of codecs for it... I don't know exactly when, but
>>> at some point I no longer had sound with youtube  and other web
>>> videos.  The videos played fine, just no sound.  Note that using vlc,
>>> both video and the audio with it play just fine.  I need to select the
>>> audio driver (from a list in a vlc menu), however, else the sound
>>> won't work in vlc either.
>>> If I go into the Applications menu, then System Tools -> Settings ->
>>> Sound, under "Choose a device for sound output:" there are no devices
>>> listed.  There used to be.
>>> If I run "aplayer file.wav", nothing plays (no sound at all) and I get
>>> the error "main:786: audio open error: No such file or directory".
>>> If, on the other hand, I run "aplay file.wav -D plughw:0" (i.e.,
>>> specify the/a device), I do get sound, the file does play.
>>> I ran alsa-info.sh and it posted tons of info from it on my setup at
>>> http://www.alsa-project.org/db/?f=1dba91886be054df4816000768
>>> a0f5b109947a48.
>>> Yet it still doesn't tell me what's missing.
>>> Anyone here have an idea...? or thoughts about where to look next?
>>> tia,
>>> ken
>> Still poking around my system for a solution, I found this comment at
>> the top of /usr/lib/systemd/system/alsa-state.service and two other
>> files in the same directory:
>> # Note that two different ALSA card state management schemes exist and
>>> they
>>> # can be switched using a file exist check -
>>> /etc/alsa/state-daemon.conf .
>> The /etc/alsa/state-daemon.conf file consists of one line:
>> # Remove this file to disable the alsactl daemon mode
>> I understand that a daemon continually runs, waiting for an event and
>> then acts in some way in response, but it has to mean something more in
>> this context.  Anyone familiar with the internals of this?
>> I am not on systemd right now. I'm on CentOS 6.8. However, on an openSUSE
> version I was. Sound problems were the bane of my existence forever it
> seemed. So it maye take you a while to troubleshoot this. Using JUST alsa
> you should be able to play sound files at the command line. See:
> http://www.alsa-project.org/main/index.php/Main_Page
> I think I may have installed pulse-audio to get things working under
> systemd with my GUI. What is your GUI? This may be a factor.
> --
> ------------------------------------------
> MzK
> "If evolution is outlawed,
>  only outlaws will evolve."
>             -- Jello Biafra


"If evolution is outlawed, only outlaws will evolve."
                                                          -- Jello Biafra