[CentOS] Xorg problem

Tue Apr 4 14:27:53 UTC 2017
Styma, Robert (Nokia - US/Phoenix) <robert.styma at nokia.com>

> I updated to Centos 6.8.
> Every thing is working, except Xorg does not startup.
> When I look at top, it seems that Xorg keeps trying but not
> succeeding to start.
> Any idea what the problem might be?

I had the same problem going to 6.8.   In my case the problem stemmed from the fact that my machine has a MACH64 video card.  The updated Xorg has a reference xf86LinearVidMem. I opened bug 1422622 at bugzilla.redhat.com.  This was on 2/15/2017.  So far the bug is just sitting there.

My work around was to disable the main repo's in /etc/yum.repos.d and enable 6.7 in the vault repo.  Did a distribution synchronization.  Here are the notes from what worked:  (may be line wrapping issues in what follows)

Went back to the x64 version and figured out
how to roll back to 6.7:
mount -t nfs phxbkup2:/iso/centos6.7x64 /media/CentOS
# This one failed with dependency issues
yum --disablerepo=\* --enablerepo=c6-media  --releasever=6.7 distribution-synchronization
# Erased the problem packages
yum --disablerepo=\* --enablerepo=c6-media  --releasever=6.7 erase  python-libipa_hbac-1.13.3-22.el6_8.4.x86_64 mesa-libxatracker-11.0.7-4.el6.x86_64 xorg-x11-drivers-7.3-13.4.el6.x86_64 mesa-libxatracker-11.0.7-4.el6.x86_64
yum --disablerepo=\* --enablerepo=c6-media  --releasever=6.7 erase  xcb-util xcb-util-renderutil
# Now it worked 
yum --disablerepo=\* --enablerepo=c6-media  --releasever=6.7 distribution-synchronization
# put pack the drivers
yum --disablerepo=\* --enablerepo=c6-media  --releasever=6.7 install  xorg-x11-drivers
yum --disablerepo=\* --enablerepo=c6-media  --releasever=6.7 install  python-libipa_hbac mesa-libxatracker mesa-libxatracker
#  These not available on the media and not reinstalled. python-libipa_hbac mesa-libxatracker mesa-libxatracker
# Now it worked.