[CentOS] sound problems... pulseaudio/pavucontrol

Tue Apr 4 23:28:27 UTC 2017
ken <gebser at mousecar.com>

On 04/03/2017 07:47 PM, Fred Smith wrote:
> On Mon, Apr 03, 2017 at 12:53:54PM -0400, ken wrote:
>> On 04/02/2017 01:31 PM, Kay Schenk wrote:
>>> On 03/29/2017 06:43 AM, ken wrote:
>>>> On 03/28/2017 08:53 PM, ken wrote:
>>>>> The www has failed me with this, so I'm trying you guys.  Sound worked
>>>>> great out of the box when I installed 7.2... Yay!  I could watch all
>>>>> kinds of videos, like on facebook and youtube.  And I could listen to
>>>>> most podcasts too.  But then something happened. It was either a
>>>>> kernel upgrade or that I installed vlc (for watching videos on DVD)
>>>>> and the whole stack of codecs for it... I don't know exactly when, but
>>>>> at some point I no longer had sound with youtube  and other web
>>>>> videos.  The videos played fine, just no sound.  Note that using vlc,
>>>>> both video and the audio with it play just fine.  I need to select the
>>>>> audio driver (from a list in a vlc menu), however, else the sound
>>>>> won't work in vlc either.
>>>>> If I go into the Applications menu, then System Tools -> Settings ->
>>>>> Sound, under "Choose a device for sound output:" there are no devices
>>>>> listed.  There used to be.
>>>>> If I run "aplayer file.wav", nothing plays (no sound at all) and I get
>>>>> the error "main:786: audio open error: No such file or directory".
>>>>> If, on the other hand, I run "aplay file.wav -D plughw:0" (i.e.,
>>>>> specify the/a device), I do get sound, the file does play.
>>>>> I ran alsa-info.sh and it posted tons of info from it on my setup at
>>>>> http://www.alsa-project.org/db/?f=1dba91886be054df4816000768a0f5b109947a48.
>>>>> Yet it still doesn't tell me what's missing.
>>>>> Anyone here have an idea...? or thoughts about where to look next?
>>>>> tia,
>>>>> ken
>>>> Still poking around my system for a solution, I found this comment at
>>>> the top of /usr/lib/systemd/system/alsa-state.service and two other
>>>> files in the same directory:
>>>>> # Note that two different ALSA card state management schemes exist and
>>>>> they
>>>>> # can be switched using a file exist check -
>>>>> /etc/alsa/state-daemon.conf .
>>>> The /etc/alsa/state-daemon.conf file consists of one line:
>>>>> # Remove this file to disable the alsactl daemon mode
>>>> I understand that a daemon continually runs, waiting for an event and
>>>> then acts in some way in response, but it has to mean something more in
>>>> this context.  Anyone familiar with the internals of this?
>>> I am not on systemd right now. I'm on CentOS 6.8. However, on an
>>> openSUSE version I was. Sound problems were the bane of my
>>> existence forever it seemed. So it maye take you a while to
>>> troubleshoot this. Using JUST alsa you should be able to play
>>> sound files at the command line. See:
>>> http://www.alsa-project.org/main/index.php/Main_Page
>>> I think I may have installed pulse-audio to get things working
>>> under systemd with my GUI. What is your GUI? This may be a factor.
>> Thanks for the thought.  This is quite plausible.  I did a little
>> reading at the site you suggested and then at another which was
>> linked off of that.  I didn't find anything helpful at either place
>> yet... well, except that in the audio stack alsa is just one layer;
>> jack and pulseaudio ride on top of it.  Apparently sound on linux
>> can use all of them-- and others on both of the same layers-- all at
>> the same time.  This is probably what makes the configuration of
>> them all so challenging.
>> In the middle of reading those sites I decided to see if audacity (a
>> quite sophisticated and solid program) could somehow handle sound. I
>> installed it and fired it up.  Out of the box it didn't work.  But I
>> simply had to choose the correct device from audacity's drop-down
>> menu and, viola, it would produce sound from a loaded file.  Cool.
>> Right after that, I tried running "aplay
>> /usr/share/sounds/alsa/Front_Right.wav" and that worked.  Previously
>> it didn't, although (as noted above)  that same command when
>> specifying the device did (i.e., "aplay
>> /usr/share/sounds/alsa/Front_Right.wav -D plughw:0").  So apparently
>> installing and/or running audacity fixed something, but not
>> everything.
>> Another trippy discovery:  I used rpm to verify all the files
>> installed with all the alsa* packages and there were absolutely no
>> changes to any of them... they're all exactly as they were when
>> first installed.  Since sound worked exquisitely when I first
>> installed 7.2 on this box and no alsa files have been changed since
>> then, it's hard to find the fault with alsa.
>> Although aplay is back to working without having to specify the
>> device, I still don't get sound out of youtube videos (even though I
>> checked the settings and restarted Firefox), and gnome3's System
>> Settings -> Sound still lists no devices at all.  These are two
>> major failures.
> Are you, perchance, using Firefox-52? At version 52, they switched
> Firefox to use Pulse instead of Alsa. So you'll probably need to
> fire up pavucontrol and mess with its sliders to get firefox audio
> working.

Good call, Fred.  Just today I got a message when, doing testing, a 
message came up in Firefox that I needed to install pulseaudio.* Well, I 
never installed pulseaudio, but it's already installed,** so it must 
have been installed when I first installed 7.2 on this machine.  So then 
I tried, as you suggested, to start up pavucontrol and play around with 
it.  However, pavucontrol was not installed. So yumd'd it down and 
installed, then clicked on it in the Applications -> Sound & Video menu, 
but I just got a window pop with the message, "Fatal Error: Unable to 
connect to PulseAudio: OK".  Well, at least I finally have an explicit 
statement from the system that there's a problem.

*Okay, now we know you're a psychic.  Along with that Firefox message 
was a button for more info.  I clicked and it went to a webpage which 
basically said the same thing in more detail and with a link (allegedly) 
to more info, 

**As I did a day or two ago with alsa packages, I used rpm to verify all 
the pulse* packages (rpm -qaVv pulseaudio*) and found that none of the 
files in any of the packages had been altered at all.

> I'm on Centos-7.3, and when I switched from 7.2 I found that some
> things now are controlled by pavucontrol, and not by the volume
> control in the top panel (I'm using Mate, not Gnome,... Gah, how can
> anyone stand Gnome 3.x??) It's kind of a pain, I haven't yet found
> a way to localize controls for all the various audio-producing tools
> in one place. Does anyone know how to do that?

Sorry, I've never seen anything like that.

>> Does anyone know how to restart audio in systemd?  That might still
>> be worth looking into.
# systemctl list-unit-files --type=service
alsa-restore.service                          static
alsa-state.service                            static
alsa-store.service                            static

The above command showed the three alsa services, but nothing for the 
other audio software I've been poking around in: pulseaudio, jack, oss.  
Nor did I see anything else listed which told me it had anything 
directly to do with the system's audio.  Moreover, I don't have alsa 
running as a daemon.  So unless I'm misunderstanding what systemd does, 
I don't think it's playing a role in my sound problems.

>> Before doing audacity, I tried gnome's mplayer.  Geez, is that a
>> stinky pile of code.  Just selecting a directory where a file could
>> be selected ended up locking up the app; I had to do a kill to get
>> it off my screen.  Does that actually work for anyone?  If so, what
>> kind of files or net locations does it work for?
>> Thanks once more for your thoughtful suggestions.