[CentOS] Ignoring /run/user/X

Wed Apr 12 12:26:40 UTC 2017
Tony Mountifield <tony at softins.co.uk>

In article <CABLobCMg4irXK7Cw6xYhz9g6_0Jug9_Lq33zVyHdQE-JAxoPvw at mail.gmail.com>,
Cameron Smith <cameron at networkredux.com> wrote:
> We are running into an issue relating to snmpd and the temporary partitions
> created in /run/user/ so any insight by someone with magical
> net-snmp skills would be much appreciated.
> Our monitoring app walks all our servers.
> We modify /etc/snmp/snmpd.conf on all our servers to just have one line:
> rocommunity ourcommnuityname monitor.ing.app.ip
> This has worked just fine for almost 10 years.
> Since the release of CentOS 7 we are getting alerts for partitions not
> being found during walks and these are the temporary partitions that are
> ephemeral while a user is logged in:
> /run/user/0
> /run/user/65000
> Seems if the partition is there when the monitor is set or is added while
> the monitor is active the monitor will keep looking for it and these are
> meant to go away.
> We thought "OK we can just ignore those" so we added a line to
> /etc/snmpd.conf :
> ignoredisk /run/user/*
> but that has not helped :(
> Does anybody have a recommendation on how we can stop those partitions from
> being seen on walks so we can stop being alerted about partitions for which
> we are not interested in monitoring their available space?

I had a quick play with it on a C7 VM, and found the same as you have.

It would appear that ignoredisk only allows you to specify device names
(such as /dev/sda1 or /dev/cciss/*), and not mount points. For /run and
/run/user/*, they are not mounted on devices but on tmpfs.

I tried "ignoredisk tmpfs" to see if that would work, but it didn't appear to.

It also doesn't help that the SNMP output for the mount table doesn't seem
to include a column for the device that was mounted, only for the mount point.
And all the mount points are listed as type "hrFSOther", so you can't tell
the difference between real disks, tmpfs, and so on.

You probably need to get the SRPM for net-snmp and have a look at the area
of code that process "ignoredisk".

Tony Mountifield
Work: tony at softins.co.uk - http://www.softins.co.uk
Play: tony at mountifield.org - http://tony.mountifield.org