[CentOS] fcitx-anthy request (for Japanese users)

Thu Aug 3 00:15:58 UTC 2017
H <agents at meddatainc.com>

On 08/02/2017 09:46 AM, Scott Robbins wrote:
> On Wed, Aug 02, 2017 at 09:37:06AM -0400, H wrote:
>>> Ah, also, in my .xinitrc (I boot into text mode then run startx I have,
>>> above the line calling the window manager
>>> export LC_CTYPE=en_US.UTF-8
>>> Do you have fcitx-gtk2 and fcitx-gtk3 installed?
>>> I repeat, I'm not an expert on this, my skill is in googling and finding
>>> out how others got it done, then just copying that and summarizing it. :)
>> Thank you, tried that but no difference. I have temporarily deactivated Chinese and am just trying to switch between two western languages. Again, this works fine in a terminal session but not in any GUI program I tried, including firefox, thunderbird, geany.
>> I do have both fcitx-gtk2 and fcitx-gtk3 installed.
>> I suspect there may be some configuration setting I have missed but since there is no graphical configuration utility it's hard to figure out what might be wrong by just looking at the several configuration text files.
> What about, from terminal, doing something like
> XMODIFIERS=@im=fcitx LC_CTYPE=zh_TW.Big5 GTK_IM_MODULE=fcitx firefox
> (the zh_TW.Big5 is just a guess, one that I saw googling lc_ctype for
> Chinese.).
> These are just guesses on my part. I've not had a similar issue, save for
> the firefox thing on FreeBSD that I mentioned.
Interesting, that seems to work! Will check it out more tomorrow. However, it seemed to work only for firefox (that you have on the command line), it did not work for thunderbird or geany.

The Big5 is likely not correct but I will check tomorrow.

Thought: I do have XMODIFIERS and GTK_IM_MODULE set in .bashrc:

export GTK_IM_MODULE=fcitx
export QT_IM_MODULE=fcitx
export XMODIFIERS=@im=fcitx

I guess that these settings in .bashrc are picked up by the terminal only and not by GUI applications?? If so, there is maybe another file I need to add them to?