[CentOS] Broadcom BCM4352 on Centos 7

Thu Dec 14 09:26:39 UTC 2017
Gary Stainburn <gary at ringways.co.uk>

On Monday 11 December 2017 18:50:06 Akemi Yagi wrote:
> ​As far as I know, the contents on the CentOS wiki are for CentOS 7.3 (or
> earlier) and a patch is needed to use the driver under 7.4.
> You may want to go to the ELRepo article that is referenced on that page (
> http://elrepo.org/tiki/wl-kmod
> ​ )​. The ELRepo instructions are up to date and should cover EL7.4.
> Akemi

I have followed your suggestion and all seemed fine. 

After rebooting I tried to do the modprobe but got the following:

[root at gary ~]# modprobe wl
modprobe: ERROR: could not insert 'wl': Required key not available
[root at gary ~]# 

This relates to the secure boot that is mentioned on the page. I therefore 
went through the process of disabling secure boot.  This consisted of 

[root at gary ~]# mokutil --disable-validation
password length: 8~16
input password: 
input password again: 
[root at gary ~]# 

After doing this I rebooted. As part of the reboot I was supposed to be asked 
for the password that I had just created but I wasn't. Then, after the reboot 
I tried the modprobe command but received the same error message.

Anyone got  ideas what I need to do next?