[CentOS] ntsysv and chkconfig update error

Fri Jul 7 11:26:03 UTC 2017
Mark Haney <mark.haney at neonova.net>

It was just a standard 'yum update'.  I suppose I could try removing
ntsysv, but I"m not sure that'll fix it.  It seems the 'pre-existing rpmdb
problem is the issue here. The ntsysv and chkconfig versions match in the
Error.  But the error message after the '**' mentions different ntsysv and
chkconfig versions.  (ie 1.7.2-1.el7. instead of 1.7.2-1.el7_3.1).  I'm not
sure of the significance of that unless it's a problem in the RPM builds or
the rpmdb is still wrong even after a full rebuild.

I tried to do a yum check on that server but it seemed to hang, though
since I've never run that command, it may just be REALLY slow.

On Fri, Jul 7, 2017 at 4:43 AM, James Pearson <james-p at moving-picture.com>

> Mark Haney wrote:
> >
> > We have a couple of CentOS 7 boxes that were built before I was hired to
> > clean up the kickstart script used for C7 boxes.  We had a couple of rpm
> > packages that were pre-C7 that were used and setup the old SysV Init way
> > using ntsysv and chkconfig on these boxes. (I finally fixed that in the
> > newer scripts.)  These are out in the field and I'm having to deal with
> > them as they are.  One thing I'm having trouble with is updating them
> > without this error:
> >
> >> Error: Package: ntsysv-1.7.2-1.el7_3.1.x86_64 (updates)
> >>            Requires: chkconfig = 1.7.2-1.el7_3.1
> >>            Installed: chkconfig-1.3.61-4.el7.x86_64 (@anaconda)
> >>                chkconfig = 1.3.61-4.el7
> >>  You could try using --skip-broken to work around the problem
> >> ** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
> >> ntsysv-1.7.2-1.el7.x86_64 has missing requires of chkconfig = ('0',
> >> '1.7.2', '1.el7')
> >
> > Now, I've verified the chkconfig v1.7.2 package is available on the
> > mirror we're using, I've rebuilt the RPM database and nothing has
> > worked.  I'm not even sure what the problem is at this point. Anyone
> > have any ideas?
> What yum command line did you use that gave the above errors?
> I'm not an expert on yum, but the above errors seem to indicate that 3
> versions of chkconfig are involved: 1.7.2-1.el7_3.1, 1.7.2-1.el7 and
> 1.3.61-4.el7 - not sure of the significance of this ...
> I guess you could try removing ntsysv and then trying to update
> chkconfig and then re-install ntsysv :
>   yum remove ntsysv
>   yum update chkconfig
>   yum install ntsysv
> James Pearson
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

[image: photo]
Mark Haney
Network Engineer at NeoNova
919-460-3330 <(919)%20460-3330> (opt 1) • mark.haney at neonova.net
www.neonova.net <https://neonova.net/>
<https://www.facebook.com/NeoNovaNNS/>  <https://twitter.com/NeoNova_NNS>