[CentOS] Installing support for Chinese text in Centos 7

Mon Jul 17 14:19:03 UTC 2017
H <agents at meddatainc.com>

On 07/17/2017 05:54 AM, Scott Robbins wrote:
> On Sun, Jul 16, 2017 at 11:23:08PM -0400, H wrote:
>> On 05/27/2017 10:15 PM, H wrote:
>>>> On 4/2/2017 11:27 AM, H wrote:
>>>>> Thank you, I just discovered your post. I just installed fcitx-pinyin to try out.
>>>>>>> These days, I use fcitx-anthy on CentOS (which took some work to set up,
>>>>>>> but ibus-anthy, at least, (for Japanese) worked pretty well. I have
>>>>>>> instructions, again, for Japanese, but quite possibly applicable at
>>>>>>> http://srobb.net/jpninpt.html#CentOS6
>>>>>> I'm going to add that a quick look through pkgs.org shows that CentOS-7x
>>>>>> does have packages for fcitx-pinyin and a few other Chinese engines, and it
>>>>>> might be worth considering making the switch. It seems (general impression
>>>>>> on my part) to be replacing ibus in a lot of places, in the same way ibus
>>>>>> gradually replaced scim.
>>> Still have not solved my problem above, i.e., after installing fcitx I can switch between US English and a European language but not to Chinese.
>>> I run the Mate Desktop on CentOS 7 and the configuration tool for fcitx that has been installed in the Settings Panel complains that a fcitx-config/fcitx-configtool program is missing.
>>> I have not been able to find that program on the 'net and am hoping someone else - anyone - is using fcitx for input of an Asian language in CentOS7/Mate...
> Yes, me, as mentioned above.
> Ok, do this, which is also described on my page under some other
> distributions.
> Quit X.
> Go into ~/.config/fcitx.
> Edit profile, looking for pinyan:False. Change that False to True and
> startx again.  It should then show as available.
> I think, when I decided to use fcitx on CentOS-7, I already knew about this
> method so never even looked for configtool.
>   > By the way, LibreOffice seems to have a couple of Chinese fonts installed, I am not sure I need to install additional fonts for the OS?
> Once you get it running, you can see.  Possibly not.
Scott, great, thank you very much! Changing the pinyin setting to true from false allowed me to use pinyin to type Chinese into a terminal window. One correction, though, the setting is not in ~/.config/fcitx but in ~/.config/profile.

I only had time for a very quick test of typing pinyin into a blank LibreOffice document since I am leaving on a trip. This did not work, however.

How do I get this working? In the font selection listbox there are a couple of - ugly-looking - simplified Chinese fonts but I could not get it to work. Do you have any suggestions here?