[CentOS] Fedora bugs and EOL [was Re: CentOS users: please try and provide feedback on Fedora] Boltron

Mon Jul 31 11:23:55 UTC 2017
Mark Haney <mark.haney at neonova.net>

On 07/31/2017 07:15 AM, Johnny Hughes wrote:
> On 07/30/2017 02:07 PM, Walter H. wrote:
>> On 30.07.2017 20:22, Johnny Hughes wrote:
>>> On 07/30/2017 09:41 AM, Walter H. wrote:
>>>> On 30.07.2017 14:29, Johnny Hughes wrote:
>>>>> I personally have a Fedora machine that I keep updated and do some work
>>>>> on all the time learning/testing.  I just seamlessly upgraded it from
>>>>> Fedora 25 to Fedora 26 using a couple of dnf commands .. awesome
>>>>> experience actually.
>>>> because of this feature to upgrade from one release to the next, I
>>>> thought to test this on my old computer;
>>>> fedora itself works fine, but this upgrade from 25 to 26 broke the
>>>> vmware workstaion completely ...
>>>> it doesn't work any more, any hints in net which could be found don't
>>>> work ...
>>>> and this was the goal to have a linux running with vmware workstation
>>>> instead of my old windows ...
>>>> but as it seems there is no way of achiving this ...
>>> Looking at VMWare Workstation, it does not seem to run on Fedora at all.
>>> It seems to run on :
>>>       Ubuntu 16.04
>>>       Red Hat Enterprise Linux 7.1
>>>       CentOS 7.1
>>>       Oracle Linux 7
>>>       openSUSE 13.2
>>>       SUSE Linux Enterprise Server 12
>>> So, I'm not sure how it was running on Fedora 25 to get messed up by an
>>> upgrade to Fedora 26.
>> with Fedora 25 everything worked fine, even the upgrade from VMware Wkst
>> 12.5.6 to 12.5.7 with automatic recompilation of neccessary kernel modules
>> without my intervention ...
>> and the same when a kernel upgrade among other updates occured on Fedora
>> 25, everything worked fine ...
>> but the upgrade from F25 to F26 killed my VMware Workstation :-(
>> even the updates which occured after this upgrade didn't help ...
> Running external things like VMWare Workstation (or other 3rd party
> custom compiled apps) is exactly what enterprise distros like RHEL,
> CentOS, Ubuntu LTS, SUSE SLES are designed for .. running things already
> compiled for a long period of time while providing security updates.
> It is not just kernel modules that need to be compiled to run on a give
> linux distribution, but everything that uses any specific shared
> libraries linked against has to be compatible as well as the main shared
> libraries (glibc).

Uh, I run VMWare workstation just fine on my F26 upgraded machine. No, 
it didn't work when I upgraded, but it's trivial to fix.


This link gets you a running workstation in about 5 minutes.  No, this 
wasn't really a Fedora issue, it's a VMWare issue.  You have to 
remember, Fedora /is/ bleeding edge packages and sometimes crap breaks.  
If you looked on the internet for a fix to this, you didn't look hard 
enough, this link is one of the first to pop up.  In fact, anytime a new 
kernel is installed, I check this site to see how much of a PITA it'll 
be to reboot the kernel and install the modules.

Personally, I would rather deal with these headaches on my Fedora box 
than I would on a CentOS box.  Primarily because I like the latest 
packages (in some cases I need them) and, I'm not freaked out about 
little things like VMWare Workstation needing some massaging to get nice 
with the OS.

Mark Haney
Network Engineer at NeoNova
919-460-3330 option 1
mark.haney at neonova.net