[CentOS] System Start-Up Issue

Mon Jul 3 12:07:01 UTC 2017
Chris Olson <chris_e_olson at yahoo.com>

We run several Intel-based CentOS machines.  They are all at 6.9 or 7.x.
One of each OS is Oracle VirtualBox hosted on an up to date Windows 7 system.
We use these virtual machines for checkout of new applications before they
are loaded on native CentOS platforms.  Regular weekly updates are run on
all of our CentOS machines.

I went on vacation right after an update to one of our virtual CentOS 6.9
systems so it was not restarted for a period of time.  Now it will not
complete boot-up with the gnome display never fully launched.  A progress
bar at the bottom of the start-up screen never reaches completion. We have
not been able to detect a running system on the network.

Two options for stopping the CentOS 6.9 virtual machine have been tried.
One is to "power off" and the other is to "send the shutdown message". Both
of these options appear to work properly.  The shutdown output scrolls by
very fast but it looks reasonable and the virtual machine eventually closes.

We have also tried suspending boot-up and selecting two previous working
kernels.  This yields the same result of an incomplete start up.  Shutdown
of these old kernel systems appears the same as shutdown of the newest
kernel.  However, we have not been able to determine from any of the
shutdown sequences exactly how much of the system was actually running.

Having very little experience with such start-up issues, we are at a loss
to determine how to salvage the CentOS 6.9 virtual machine.  Is there a
standard way to start up a system without any extras like gnome to see if
we can get a running system?  Would it be wise to attempt using yum update
after we get a running system to see if issues are corrected?  Thanks.