[CentOS] Sound stopped working from internal speaker in CentOS 7.2 (intel-hda) and is still broken.

Thu Jul 6 05:01:15 UTC 2017
Barry Brimer <lists at brimer.org>

This message is long overdue. I've commented on similar issues when other 
people have mentioned similar items, but I am finally taking the time to 
to ask this question.

Did anyone else have the sound from their internal speaker stop working 
with the release of CentOS 7.2?

I have tested this with multiple machines with the same card and the same 

The card is identified as:

!!PCI Soundcards installed in the system

00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio 
Controller (rev 02)

!!Advanced information - PCI Vendor/Device/Subsystem ID's

00:1b.0 0403: 8086:3a6e (rev 02)
         Subsystem: 17aa:3048

At the release of CentOS 7.2, sound stopped working from the internal 
speaker. I could still plug in headphones and get audio without issue, but 
I can't use the speaker. This breaks between the last update kernel of 
CentOS 7.1 and the GA kernel of 7.2 and is still broken as of the latest 
7.3 kernel.

I have captured alsa-info.sh output from the following kernels:

kernel-3.10.0-229.20.1.el7.x86_64 <== Last kernel which produces sound 
from internal speaker. If booted with this kernel, sound is produced from 
the internal speaker. This was the last update kernel before CentOS 7.2

kernel-3.10.0-327.el7.x86_64 <== 7.2 GA kernel. Sound is not produced from 
internal speaker.

kernel-3.10.0-514.26.2.el7.x86_64 Current 7.3 update kernel. Sound is not 
produced from internal speaker.

I have tried eliminating alsa, as directed in Fedora sounds 
by removing alsa-plugins-pulseaudio

I have tried creating /etc/modprobe.d/sound.conf file with the 
following contents:
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=6stack
options snd-hda-intel position_fix=1 enable=yes

I have tried listing and unmuting all devices alsa using scripts from 

The only thing which appears relevant that is mentioned in the RHEL 7.2 
release notes is:
"The HDA driver has been updated to the latest upstream version to use 
the new jack kctls method."

In reviewing the changelog there are a handful of sound/alsa related 
changes in 3.10.0-318.el7 and prior to that, there were an immense number 
of sound/alsa changes in 3.10.0-278.el7.

The most specific thing that I can state is that in the working kernel, in 
alsamixer there is a second box which appears to be a level which can be 
adjusted on top of the item "Front" which I assume to be the front 
speaker. In the kernels that do not have sound working, this second 
level-looking box does not appear.

I welcome any and all suggestions.