[CentOS] qemu-system-x86_64 does not support fw_cfg option

Wed Jul 26 10:20:04 UTC 2017
Steve Rubie-Todd <steve at rubie-todd.com>


I am trying to run CoreOS (Container Linux) as a guest OS using 
KVM/QEMU. One of their suggestions is to pass config info into the VM 
using the "fw_cfg" option . When I try this I get the error "-fw_cfg 
invalid option". If I run the vm with the help option it does not list 
the fw_cfg option. However, according to the qemu documentation, see 
they support this option.

The command used to run the vm is:

    /usr/bin/qemu-system-x86_64 -name CL-IGN-1 -m 1024 \
         -net nic,vlan=0,model=virtio \
         -net user,vlan=0,hostfwd=tcp::2222-:22,hostname=CL-IGN-1 \
         -drive if=virtio,file=./coreos_production_qemu_image.img \
         -fw_cfg name=opt/com.coreos/config,file=./CL-IGN-1.ignconfig

    qemu-system-x86_64: -fw_cfg: invalid option

I also tried using /usr/libexec/qemu-kvm but got the same error.

I am running::

    CentOS Linux release 7.3.1611 (Core)