[CentOS] C7, systemd, say what?!

Thu Jun 8 11:48:58 UTC 2017
Bruce Ferrell <bferrell at baywinds.org>

On 6/8/17 1:15 AM, Veli-Pekka Kestilä wrote:
> On 7.6.2017 23:40, Bruce Ferrell wrote:
>> On 06/07/2017 01:27 PM, Warren Young wrote:
>>> On Jun 7, 2017, at 1:02 PM, John R Pierce <pierce at hogranch.com> wrote:
>>>> every RPM that interacts with systemd will need to be 'fixed' to do 
>>>> it the old way, with init.d scripts. repositories like postgres, 
>>>> EPEL, etc won't work, either, as their C7 packaged daemons are all 
>>>> configured to use systemd.
>>> That’s just skimming the surface.
>>> The real hard bits come from the way systemd hooks into the whole 
>>> FreeDesktop infrastructure and vice versa.  (e.g. dbus is now 
>>> inextricably part of systemd, and many FreeDesktop interactions 
>>> happen via dbus.)  This is why the BSDs are either dropping GNOME 
>>> and KDE (e.g. Lumina in TrueOS) or have badly lagging ports compared 
>>> to the upstream version.
>>> I suspect it’s probably easier to start with C6, then backport as 
>>> much as is possible without dragging in any systemd stuff, the same 
>>> way the BSDs are doing.
>>> Good luck to y’all.  Sincerely.  I plan to keep on using C7, warts 
>>> and all.
>> As I mentioned previously.  Scientific Linux (another RHEL clone) HAS 
>> solved those issues.  Centos isn't running the latest KDE/Plasma5 junk.
> How they have solved it? According SL7 release notes in:
> http://ftp.scientificlinux.org/linux/scientific/7.0/x86_64/release-notes/
> They say following:
> "Following upstream SL7 uses systemd as its init system. The System’s 
> Administrators Guide published by upstream provides a helpful 
> introduction to systemd commands."
> -vpk 
Yes, 7 does track upstream.  upstream 6 uses systemd also and Scientific 
Linux 6 does not.  I would say that indicates a solution.