[CentOS] sound problems... config?

Wed Mar 29 03:40:35 UTC 2017
Alice Wonder <alice at domblogger.net>

On 03/28/2017 05:53 PM, ken wrote:
> The www has failed me with this, so I'm trying you guys.  Sound worked
> great out of the box when I installed 7.2... Yay!  I could watch all
> kinds of videos, like on facebook and youtube.  And I could listen to
> most podcasts too.  But then something happened. It was either a kernel
> upgrade or that I installed vlc (for watching videos on DVD) and the
> whole stack of codecs for it... I don't know exactly when, but at some
> point I no longer had sound with youtube  and other web videos.  The
> videos played fine, just no sound.  Note that using vlc, both video and
> the audio with it play just fine.  I need to select the audio driver
> (from a list in a vlc menu), however, else the sound won't work in vlc
> either.
> If I go into the Applications menu, then System Tools -> Settings ->
> Sound, under "Choose a device for sound output:" there are no devices
> listed.  There used to be.
> If I run "aplayer file.wav", nothing plays (no sound at all) and I get
> the error "main:786: audio open error: No such file or directory".  If,
> on the other hand, I run "aplay file.wav -D plughw:0" (i.e., specify
> the/a device), I do get sound, the file does play.
> I ran alsa-info.sh and it posted tons of info from it on my setup at
> http://www.alsa-project.org/db/?f=1dba91886be054df4816000768a0f5b109947a48.
> Yet it still doesn't tell me what's missing.
> Anyone here have an idea...? or thoughts about where to look next?
> tia,
> ken

I have similar issue with USB headphones. Worked fine in 7.2 but in 7.3 
I frequently have to unplug and plug them back in before it finally is 
able to be selected from the menus as my output.

Once it is selected, it stays selected until next reboot.