[CentOS] sound problems... config?

Thu Mar 30 12:58:31 UTC 2017
ken <gebser at mousecar.com>

On 03/29/2017 12:08 PM, Alice Wonder wrote:
> On 03/29/2017 04:05 AM, ken wrote:
>> On 03/28/2017 11:40 PM, Alice Wonder wrote:
>>> On 03/28/2017 05:53 PM, ken wrote:
>>>> The www has failed me with this, so I'm trying you guys.  Sound worked
>>>> great out of the box when I installed 7.2... Yay!  I could watch all
>>>> kinds of videos, like on facebook and youtube.  And I could listen to
>>>> most podcasts too.  But then something happened. It was either a 
>>>> kernel
>>>> upgrade or that I installed vlc (for watching videos on DVD) and the
>>>> whole stack of codecs for it... I don't know exactly when, but at some
>>>> point I no longer had sound with youtube  and other web videos. The
>>>> videos played fine, just no sound.  Note that using vlc, both video 
>>>> and
>>>> the audio with it play just fine.  I need to select the audio driver
>>>> (from a list in a vlc menu), however, else the sound won't work in vlc
>>>> either.
>>>> If I go into the Applications menu, then System Tools -> Settings ->
>>>> Sound, under "Choose a device for sound output:" there are no devices
>>>> listed.  There used to be.
>>>> If I run "aplayer file.wav", nothing plays (no sound at all) and I get
>>>> the error "main:786: audio open error: No such file or directory".  
>>>> If,
>>>> on the other hand, I run "aplay file.wav -D plughw:0" (i.e., specify
>>>> the/a device), I do get sound, the file does play.
>>>> I ran alsa-info.sh and it posted tons of info from it on my setup at
>>>> http://www.alsa-project.org/db/?f=1dba91886be054df4816000768a0f5b109947a48. 
>>>> Yet it still doesn't tell me what's missing.
>>>> Anyone here have an idea...? or thoughts about where to look next?
>>>> tia,
>>>> ken
>>> I have similar issue with USB headphones. Worked fine in 7.2 but in
>>> 7.3 I frequently have to unplug and plug them back in before it
>>> finally is able to be selected from the menus as my output.
>>> Once it is selected, it stays selected until next reboot.
>> Alice,
>> Thanks for your reply.  I believe you and I are looking at two separate
>> problems.  My system is capable of switching between the onboard
>> speakers and the headphones with no problem at all (when the sound is
>> working at all).  That is, when there's sound out of the onboards, I can
>> plug in the headphones and sound instantly comes out of them, and vice
>> versa... even in the middle of one and the same video.
>> In your case the problem may have more to do with USB.  USB is
>> notoriously slow... at least it used to be.  This is due to timing,
>> i.e., after loading the USB sub-system, the system has to query the USB
>> device to find out what it is (e.g., mouse, joystick, headphones,
>> touchpad, etc.) and there are a bazillion different kinds of USB
>> devices... a long list of things to query.  Not only that, but a single
>> query takes time: the system has to give the device time to respond-- it
>> used to be a second or two.   And there are ever more USB devices.
>> Maybe too your headphones are near the bottom of the long list of USB
>> devices.
>> I don't know that this is your situation.  It could be something else (a
>> half dozen other hang-ups).  But you might want to test by plugging in
>> your USB headphones and then leaving the plug in, waiting a couple
>> minutes to see if they start to work.
>> Alice, could you please post the output of these three commands (for
>> comparison purposes):
>> uname -r
>> ps -ef|grep -i alsa
>> aplayer -L
>> Thanks.
> [alice at localhost ~]$ uname -r
> 3.10.0-514.6.2.el7.x86_64

It looks like either you need to do a kernel upgrade or you haven't 
rebooted since the most recent.  I have 3.10.0-514.10.2.el7.x86_64.

> [alice at localhost ~]$ ps -ef |grep -i alsa
> root       858     1  0 Feb27 ?        00:00:00 /usr/sbin/alsactl -s 
> -n 19 -c -E ALSA_CONFIG_PATH=/etc/alsa/alsactl.conf 
> --initfile=/lib/alsa/init/00main rdaemon

This is the same as what I have.  So the same command is fired up to run 
alsa.  I looked at the two files (both text files) and they're both, to 
me, inscrutable.  The second one, is actually a program, code which 
programmatically configures alsactl.  The programming language it uses 
is fairly normal and simple, but even with that, with all the variables 
and other files it uses and various operations it invokes, and then all 
the knowledge of internals of audio and the sound card it entails, it 
would take quite a bit of study to get a grip on it.  Getting some human 
help there or a good doc or two  (in addition to its man page) might 
even make it possible to fathom...  :)  then possibly happen onto the fix.

> [alice at localhost ~]$ aplayer -L
> bash: aplayer: command not found...

Sorry, Alice.  I shouldn't have trusted memory.  The actual command is 
"aplay -L".

> -=-
> Intel xeon on supermicro board


> No onboard sound but unfortunately the video card has Intel HD audio 
> associated with the HDMI out that for some reason the system always 
> defaults to after boot even though there is no audio out on the video 
> card (nvidia card) other than the HDMI which I only use for video.

Your system doesn't have a plug (typically a three- or four-connector 
(sub)mini-D) for analog sound?

> I had blacklisted the Intel HD and that worked under CentOS 7.2 but I 
> couldn't USB audio to work in 7.3 until I removed the blacklisted 
> Intel HD driver, but I'm not sure if that was cause and effect or 
> coincidence.
> I really wish USB sound would "just work" and that the sound 
> preferences would remember I prefer USB after a reboot. Linux use to 
> be better about that sort of thing. 

Well, it can't remember what it can't do properly in the first place.  
Have you compared lsmod output prior to plugging into USB to lsmod 
output when plugged in and functioning properly?