[CentOS] Centos 7 and MAC address munging

Thu May 18 14:03:28 UTC 2017
m.roth at 5-cent.us <m.roth at 5-cent.us>

Subject: Re: [CentOS] Centos 7 and MAC address munging
Date: Thu, 18 May 2017 06:22:21 +0100
From: James Hogarth <james.hogarth at gmail.com>
> On 17 May 2017 8:53 pm, <m.roth at 5-cent.us> wrote:
>> Odd situation: I've mentioned before that I have several users for whom I
>< have to spoof the MAC address, due to a software license. Now, I've got
>> net.ifnames=0 biosdevname=0 on the grub2 command line, and I've got the
>> spoofed MAC address in /etc/sysconfig/network-sctipts/ifcfg-eth0.
>> But he had a serious problem - X froze, and he thought to reboot, rather
>> than call me. It came up with the actual MAC. I tried a number of things,
>> including reboots, but the only thing that worked was systemctl stop
>> NetworkManager, ifdown eth0, then ifup eth0, then start NetworkMangler,
>> and all was good.
>> Yeah, I know, afterwards, I remembered I should have use nmcli....
>> But the real question is *why* did it fail on the reboot. I find no clues
>> in dmesg, or messages, or boot.log.
>> Clues for the poor?
> Is this box fully updated? I ask as the NM since 7.3 has different
> behaviour from release due to rebasing.

Mostly. Running 3.10.0-514.10.2.el7.x86_64, and yum tells me nothing
marked for update (that's ignoring that we have exclude=kernel* *xorg*
*nvid* kmod* in yum.conf)
> What does `nmcli con sh eth0 | grep clone` tell you?
802-3-ethernet.cloned-mac-address: and the spoofed MAC address.

> It's that property you need to set.

Sorry, I don't understand the above sentence. What property -
802-3-ethernet.cloned-mac-address? And this is on top of ifcfg-eth0, and
all the rest?