[CentOS] CentOS 7 cloned VM cannot boot

Wed May 3 14:24:39 UTC 2017
Nikolaos Milas <nmilas at noa.gr>


I'm struggling to make a cloned CentOS 7 VM (under KVM) to work.

The VM was cloned using mondorestore. Restore appears successful but the 
VM won't boot; see:


I booted with CentOS 7 disk in troubleshooting mode (where the virtual 
disk was automatically mounted without issues) and I tried to repair:



# grub2-mkconfig -o /boot/grub2/grub.cfg
/usr/sbin/grub2-probe: error: unknown filesystem.

I then tried to repair using: 
https://sourceforge.net/p/boot-repair-cd/home/Home/ but it didn't manage 
to solve the problem. (It reported success but the VM still won't boot.)

More interesting was the effort with the supergrub2 disk: 

This managed to identify the available "boot methods" and allowed me to 
boot correctly. See screenshots:


Once I logged in, I checked /etc/fstab and /boot/grub2/grub.cfg but I 
didn't see any obvious problem. The are here as well:


However, I also followed these directions: 
to rebuild grub2.conf. The commands were completed successfully.

Unfortunately, the OS still won't boot: same issue, see:


I again tried to boot using the supergrub2 disk; this time the boot 
method detection produced the (slightly different) list you see in image:


Using the supergrub2 disk I can boot and login successfully. Otherwise 
(i.e. directly) the box won't boot.

As I know little about grub2 (and low-level linux) to troubleshoot the 
issue, can you please help identify and correct the problem? Why the VM 
always refuses to boot?

Which is the reported device (on image -04) that remains unrecognized? I 
looked into /boot/grub/grub2.cfg but I didn't see any such UUID there. 
Where may it be referenced to be used during the boot process?

Note: I never have such issues when restoring (using mondorestore) 
CentOS 5 or CentOS 6 mondoarchive backups (even on dissimilar virtual 

Can you please help me identify the problem, based on the above info, 
and make the VM normally bootable?

Many thanks,