[CentOS] Installing support for Chinese text in Centos 7

Sun May 28 02:15:42 UTC 2017
H <agents at meddatainc.com>

On 04/07/2017 10:12 AM, H wrote:
> I installed fcitx-pinyn, and its dependencies, and I now have ZH as a choice but have not been able to type pinyin and get a list of Chinese characters to choose among like I could on CentOS 6. Does anyone have it working?
> On 4/2/2017 11:27 AM, H wrote:
>> Thank you, I just discovered your post. I just installed fcitx-pinyin to try out.
>> On 02/25/2017 09:04 PM, Scott Robbins wrote:
>>> On Sat, Feb 25, 2017 at 08:51:41PM -0500, Scott Robbins wrote:
>>>> On Sat, Feb 25, 2017 at 08:42:43PM -0500, H wrote:
>>>>> I have just done a minimal installation of Centos7 followed by X Windows and the Mate desktop on a workstation. Although the default language is English, I would like to be able to write Chinese text in various applications.
>>>>> I seem to remember this was very easy to do in Centos 6 and Gnome: possibly only requiring only a simple 'yum groupinstall "Chinese Support"' after which I could use iBus to switch between languages. This does not seem to work in Centos 7.
>>>> These days, I use fcitx-anthy on CentOS (which took some work to set up,
>>>> but ibus-anthy, at least, (for Japanese) worked pretty well. I have
>>>> instructions, again, for Japanese, but quite possibly applicable at
>>>> http://srobb.net/jpninpt.html#CentOS6
>>> I'm going to add that a quick look through pkgs.org shows that CentOS-7x
>>> does have packages for fcitx-pinyin and a few other Chinese engines, and it
>>> might be worth considering making the switch. It seems (general impression
>>> on my part) to be replacing ibus in a lot of places, in the same way ibus
>>> gradually replaced scim.
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> https://lists.centos.org/mailman/listinfo/centos
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

Still have not solved my problem above, i.e., after installing fcitx I can switch between US English and a European language but not to Chinese.

I run the Mate Desktop on CentOS 7 and the configuration tool for fcitx that has been installed in the Settings Panel complains that a fcitx-config/fcitx-configtool program is missing.

I have not been able to find that program on the 'net and am hoping someone else - anyone - is using fcitx for input of an Asian language in CentOS7/Mate...

By the way, LibreOffice seems to have a couple of Chinese fonts installed, I am not sure I need to install additional fonts for the OS?