[CentOS] Kickstart ksdevice question

Fri Nov 3 14:19:30 UTC 2017
Mark Haney <mark.haney at neonova.net>

On 11/01/2017 05:02 PM, James A. Peltier wrote:
> Leaving ksdevice= off the command line will prompt you for the location of the kickstart file and the device you want to use to kickstart
Well, things just got weird with this.  The first couple of times I 
included the biosdevname etc, on the command line with ksdevice=eth0 it 
worked perfectly.  Sometime yesterday (and I verified this a few minutes 
ago) that stopped working.  It's the same hardware (in fact, the exact 
same hardware as I tested earlier, as it's the same box) and now, it's 
naming the interfaces eno1/eno2 again.

Honestly, not that I care, since taking the ksdevice= bit off worked 
just fine, even with the interface names changed to eth0/eth1 in the 
kickstart file. I have no idea why this happened, and finding an answer 
isn't critical to getting these boxes kicked, though I would like to 
understand why the BIOSDEVNAME NET.IFRAMES options stopped working 
suddenly.  It's the same boot image, and the exact same server that 
renamed the interfaces correctly yesterday.  Granted, it's Friday and 
maybe anaconda is tired of my crap and has decided to throw a tantrum.

Mark Haney
Network Engineer at NeoNova
919-460-3330 option 1
mark.haney at neonova.net