[CentOS] how do I use CDC usb ports?

Tue Nov 7 19:52:10 UTC 2017
Michael Hennebry <hennebry at web.cs.ndsu.nodak.edu>

I want to use a USB CDC port.
I was under the impression that they were not all that hard to use.
'Tain't going well for me.

lsusb | grep ega
tells me
Bus 007 Device 007: ID 2341:0042 Arduino SA Mega 2560 R3 (CDC ACM)
As root, cat-ing /dev/bus/usb/007/007  gives me garbage.
As anyone else, I get a permission denied error.
Usually, though not lately, a /dev/ttyS? shows up at about
the same time as the .../007/* device.

How, without continuously running as root,
do I get access to CDC usb devices?
I've tried making myself a member of dialout,
but it doesn't seem to take.
I've tried both lgroupmod -M hennebry dialout
oIt doesn't seem to take.and usermod -a -G dialout hennebry .

How do I tell which one I want?
I'm guessing I can't use /dev/bus/... .
How do I tell which /dev/ttyS? I want?

Michael   hennebry at web.cs.ndsu.NoDak.edu
"Sorry but your password must contain an uppercase letter, a number,
a haiku, a gang sign, a heiroglyph, and the blood of a virgin."
                                                              --  someeecards