[CentOS] home on nfs

Mon Oct 30 16:02:08 UTC 2017
hw <hw at adminart.net>

Jonathan Billings <billings at negate.org> writes:

> On Oct 28, 2017, at 23:15, hw <hw at adminart.net> wrote:
>> Jonathan Billings <billings at negate.org> writes:
>>>> On Oct 27, 2017, at 10:21, hw <hw at adminart.net> wrote:
>>>> Hi,
>>>> I have the home directory of a user on an nfs server and mount it on a
>>>> client.  When the user logs in, they end up in the root directory rather
>>>> than in their actual home directory and need to cd into it.
>>>> The user can read and write to their home directory, so it kinda works
>>>> fine --- but only kinda.  When the user starts emacs, some of the
>>>> settings in ~/.emacs are not applied, but the saved desktop is being
>>>> loaded.
>>>> Both machines are running Centos 7.4.  What could be wrong with the nfs
>>>> mount?
>>> Sounds like you haven’t set the selinux Boolean for NFS homedirs. 
>>> setsebool -P use_nfs_home_dirs 1
>> Oh, indeed, I didn´t know that I need to do that.
>> Do I do this on the client or on the server or both?
> Just the client. 

Thanks, I tried that and it works now :)

"Didn't work" is an error.