[CentOS] Lock-up during boot when Logitech unifying receiver is connected (UEFI problem?)

Tue Oct 10 09:39:10 UTC 2017
Toralf Lund <toralf.lund at pgs.com>


I've got a bit of an issue after I switched to a new laptop for my 
CentOS 6.9 installation: I'm using a Logitech cordless keyboard and 
mouse that communicate with the system via a so-called "unifying 
receiver". If this unit (a small USB thingummy) is connected when I try 
to boot the system, it locks up completely. This happens before the GRUB 
screen is displayed. The set-up otherwise works just fine, i.e. I notice 
no ill effects of connecting the receiver once the system is up-and-running.

I did not not have this problem on my old laptop, which ran a more or 
less identical Linux configuration (I cloned the partition.) Something 
that's new, though, is that I now have GPT partitions and boot using 
UEFI, where the old PC used  traditional BIOS. I also had a hard time 
installing in the first place because I got similar issues when trying 
to boot the installer as well as "stand-alone" tools like "parted" and 
"clonezilla" from USB sticks, and these seemed to be restricted to GPT 
and UEFI, too. (I didn't realise at the time that the unifying receiver 
was the problem, so I ended up installing via "legacy" boot.)

Has anyone else seen this? Any suggestions? I can live with the problem, 
I guess, but having to unplug and reconnect the unit every time I boot 
is a bit annoying.

I've tried connecting the unit to several different USB ports, with the 
same result. I've also searched for firmware updates, but didn't find 


- Toralf