[CentOS] libimoblidevice prevents updating to Centos7.4 - yum failed installs, horked sound

Sat Sep 16 03:43:44 UTC 2017
ken <gebser at mousecar.com>

On 09/15/2017 08:02 AM, johan.vermeulen7 at telenet.be wrote:
> ----- Oorspronkelijk bericht -----
> Van: "Richard" <lists-centos at listmail.innovate.net>
> Aan: "CentOS mailing list" <centos at centos.org>
> Verzonden: Vrijdag 15 september 2017 13:03:27
> Onderwerp: Re: [CentOS] libimoblidevice prevents updating to Centos7.4
>> Date: Friday, September 15, 2017 05:34:11 -0500
>> From: Johnny Hughes <johnny at centos.org>
>> On 09/15/2017 03:06 AM, johan.vermeulen7 at telenet.be wrote:
>>> Hello All,
>>> this problem occured both before the release with CR repo and now
>>> after the release.  I have 150 laptops running Centos7 / MATe,
>>> including my own laptop.
>>> We have these repo's enabled:
>>> repo id repo naam status
>>> base/7/x86_64 CentOS-7 - Base 9.591
>>> beid-release/7 Belgian eID package archive 68
>>> epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 11.904
>>> extras/7/x86_64 CentOS-7 - Extras 196
>>> google-talkplugin google-talkplugin 1
>>> nux-dextop/x86_64 Nux.Ro RPMs for general desktop use 2.489
>>> updates/7/x86_64
>>> When updating I get EM:
>>> Fout: Pakket: libgpod-0.8.3-14.el7.x86_64 (@epel)
>>> Vereist: libusbmuxd.so.2()(64bit)
>>> Verwijderen: usbmuxd-1.0.8-11.el7.x86_64 (@base)
>>> libusbmuxd.so.2()(64bit)
>>> Nieuwer pakket is:: usbmuxd-1.1.0-1.el7.x86_64 (base)
>>> Niet gevonden
>>> Fout: Pakket: libgpod-0.8.3-14.el7.x86_64 (@epel)
>>> Vereist: libplist.so.1()(64bit)
>>> Verwijderen: libplist-1.10-4.el7.x86_64 (@base)
>>> libplist.so.1()(64bit)
>>> Bijgewerkt door: libplist-1.12-3.el7.x86_64 (base)
>>> ~libplist.so.3()(64bit)
>>> Fout: Pakket: libgpod-0.8.3-14.el7.x86_64 (@epel)
>>> Vereist: libimobiledevice.so.4()(64bit)
>>> Verwijderen: libimobiledevice-1.1.5-6.el7.x86_64 (@base)
>>> libimobiledevice.so.4()(64bit)
>>> Bijgewerkt door: libimobiledevice-1.2.0-1.el7.x86_64 (base)
>>> ~libimobiledevice.so.6()(64bit)
>>> Je zou kunnen proberen met behulp van --skip-broken het probleem
>>> te omzeilen  Je zou kunnen proberen: rpm -Va --nofiles --nodigest
>>> What I've been doing for a few weeks when using CR repo is remove
>>> libimobiledevice and reinstall:

I've had a similar symptom... plus a couple other problems today:

Today, when I ran "yum update", there were about 700 or 800 packages 
which tried to update.  Only about 20 successfully installed, all the 
others failed due to dependency problems.  But I found that if I picked 
just one or three or a half dozen packages out from the huge list of 
failures, they would update successfully, including the dependencies 
they required.  Doing this repeatedly, I successfully updated most of 
those 800-some packages.  Only 16 still wouldn't install due to 
dependency issues, the same packages as listed above, i.e.:

Packages skipped because of dependency problems:
     gvfs-1.30.4-3.el7.x86_64 from base
     gvfs-afc-1.30.4-3.el7.x86_64 from base
     gvfs-afp-1.30.4-3.el7.x86_64 from base
     gvfs-archive-1.30.4-3.el7.x86_64 from base
     gvfs-client-1.30.4-3.el7.x86_64 from base
     gvfs-fuse-1.30.4-3.el7.x86_64 from base
     gvfs-goa-1.30.4-3.el7.x86_64 from base
     gvfs-gphoto2-1.30.4-3.el7.x86_64 from base
     gvfs-mtp-1.30.4-3.el7.x86_64 from base
     gvfs-smb-1.30.4-3.el7.x86_64 from base
     libimobiledevice-1.2.0-1.el7.x86_64 from base
     libplist-1.12-3.el7.x86_64 from base
     libusbmuxd-1.0.10-5.el7.x86_64 from base
     upower-0.99.4-2.el7.x86_64 from base
     usbmuxd-1.1.0-1.el7.x86_64 from base

In addition, subsequent to this (mostly successful) update, the sound no 
longer functions.  Even audacity and vlc produce no sound, and they have 
always worked, even when all other sound apps on this system didn't.

It's perhaps worth noting that I don't have mate installed and have had 
no network problems since this major, partially horked update.

At this initial stage I'm suspecting a problem with yum or rpm (both of 
which were in the huge list of updated packages).  For instance, vim was 
one of the many packages which failed due to "dependency" issues.. until 
I updated it separately, by itself.

Does this lead anyone to suggest a solution, or a next step?